summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-10-14 00:01:12 +0200
committerMarius Bakke <marius@gnu.org>2021-10-14 00:01:12 +0200
commit0f77e50139b023cb1a5a82ac3a0b9b7fa990c45b (patch)
tree8796bb011e021bf01fe5cb15c70641ee0c0ed5f0 /gnu/packages/golang.scm
parent641b31de5e9716ff8bd088f4834c98d4a664b55a (diff)
parent1961b28445080c7b9fb8bf5291ac9a814303522a (diff)
downloadguix-patches-0f77e50139b023cb1a5a82ac3a0b9b7fa990c45b.tar
guix-patches-0f77e50139b023cb1a5a82ac3a0b9b7fa990c45b.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5786da586c..51bd9686ec 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2680,6 +2680,41 @@ time.")
(home-page "https://godoc.org/golang.org/x/xerrors")
(license license:bsd-3))))
+(define-public go-golang-org-x-mod
+ (let ((commit "0f08993efd8a8ec67e75bcccf86b0e1569b0ab0a")
+ (revision "0"))
+ (package
+ (name "go-golang-org-x-mod")
+ (version (git-version "0.5.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/x/mod")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pl0jc5jvg7hxj4z66zg6kglnq5g7li09f3k9klwvyr4jx5dw88k"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "golang.org/x/mod/"
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ ;; Source-only package
+ (delete 'build))))
+ (home-page "https://golang.org/x/mod")
+ (synopsis "Tools to work directly with Go module mechanics")
+ (description
+ "This repository holds packages for writing tools that work directly
+with Go module mechanics. That is, it is for direct manipulation of Go modules
+themselves.
+
+The specific case of loading packages should still be done by invoking the
+@command{go} command, which remains the single point of truth for package
+loading algorithms.")
+ (license license:bsd-3))))
+
(define-public go-github-com-burntsushi-toml
(package
(name "go-github-com-burntsushi-toml")