summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-11-08 21:35:55 -0600
committerEfraim Flashner <efraim@flashner.co.il>2021-01-03 17:24:27 +0200
commit0d8f28e9de3e14b5eba58e551b674f54a3294aae (patch)
tree6eeaf51ef568f06d0aad9cbf84f0495605888f13 /gnu/packages/golang.scm
parent0a7d6e87bb2d56d68cc4e8d09860c9aa494485ac (diff)
downloadguix-patches-0d8f28e9de3e14b5eba58e551b674f54a3294aae.tar
guix-patches-0d8f28e9de3e14b5eba58e551b674f54a3294aae.tar.gz
gnu: Add go-github-com-golangplus-testing.
* gnu/packages/golang.scm (go-github-com-golangplus-testing): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cd5644bb0f..64afc4b48d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -507,6 +507,28 @@ jar struct to manage the cookies added to the cookie jar.")
(description "This package provides additions to Go's stdlib @code{fmt}.")
(license license:bsd-3)))
+(define-public go-github-com-golangplus-testing
+ (package
+ (name "go-github-com-golangplus-testing")
+ (version "1.0.0")
+ (home-page "https://github.com/golangplus/testing")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1a29m4zplf9m14k74lrb55dids2l17vx28sv0g3y3qcv1xygksiv"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/golangplus/testing"))
+ (propagated-inputs
+ `(("go-github-com-golangplus-fmt" ,go-github-com-golangplus-fmt)))
+ (synopsis "Additions to Go's standard testing package")
+ (description "This package provides additions to Go's stdlib testing.")
+ (license license:bsd-3)))
+
(define-public go-github-com-leodido-go-urn
(package
(name "go-github-com-leodido-go-urn")