summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-01-02 21:44:51 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-01-02 22:38:59 +0100
commit07f7bf3624b519498b694825eb6b9b0f45af7492 (patch)
tree57324609f61c41828973503a58bad492e534e7cc /gnu/packages/golang.scm
parent08e69c79dc729a5bc95e218d8e4569072b8a4a79 (diff)
downloadguix-patches-07f7bf3624b519498b694825eb6b9b0f45af7492.tar
guix-patches-07f7bf3624b519498b694825eb6b9b0f45af7492.tar.gz
gnu: Add go-github-com-fatih-color.
* gnu/packages/golang.scm (go-github-com-fatih-color): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 76b93c0d14..5d2eef699b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3036,3 +3036,25 @@ on running processes and system utilization (CPU, memory, disks, network,
sensors).")
(home-page "https://github.com/shirou/gopsutil")
(license license:bsd-3))))
+
+(define-public go-github-com-fatih-color
+ (package
+ (name "go-github-com-fatih-color")
+ (version "1.8.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fatih/color.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zc0zlilf03h121f9jqq3ar0hfm7706547zysxp2qxbm920pz7h0"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/fatih/color"))
+ (synopsis "Print colored text in Go")
+ (description "This package provides an ANSI color package to output
+colorized or SGR defined output to the standard output.")
+ (home-page "https://godoc.org/github.com/fatih/color")
+ (license license:expat)))