summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-03-19 16:14:51 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-03-20 11:19:29 +0100
commit05d261b88e6fb86abeaa321a7ce44d9f7798cbd5 (patch)
treea17584f60e2abfc00e9e5e63ca75ef81553ecf19 /gnu/packages/golang.scm
parent81aa7cea643099c8fa0b458d1319e9f412177881 (diff)
downloadguix-patches-05d261b88e6fb86abeaa321a7ce44d9f7798cbd5.tar
guix-patches-05d261b88e6fb86abeaa321a7ce44d9f7798cbd5.tar.gz
gnu: Add go-honnef-co-go-tools.
* gnu/packages/golang.scm (go-honnef-co-go-tools): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4c2fb2acb7..1ad1e149a7 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6968,3 +6968,36 @@ reformat the source code, it only prints out style mistakes.")
@code{cmd/go} tool, provided as a convenience to developers who want to write
tools with similar semantics.")
(license license:expat)))
+
+(define-public go-honnef-co-go-tools
+ (package
+ (name "go-honnef-co-go-tools")
+ (version "0.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dominikh/go-tools")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17li8jbw3cpn59kpcl3j3r2an4wkx3fc81xn0j4xgbjpkxh9493n"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "honnef.co/go/tools"
+ #:tests? #f
+ ;; Source-only package
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'build))))
+ (propagated-inputs
+ `(("go-golang-org-x-tools" ,go-golang-org-x-tools)
+ ("go-github-com-kisielk-gotool",go-github-com-kisielk-gotool)
+ ("go-github-com-burntsushi-toml" ,go-github-com-burntsushi-toml)))
+ (home-page "https://honnef.co/go/tools")
+ (synopsis "Staticcheck advanced Go linter")
+ (description
+ "Staticcheck is a state of the art linter for the Go programming language.
+Using static analysis, it finds bugs and performance issues, offers
+simplifications, and enforces style rules.")
+ (license license:expat)))