summaryrefslogtreecommitdiff
path: root/gnu/packages/gobby.scm
diff options
context:
space:
mode:
authorAndy Wingo <wingo@igalia.com>2016-09-27 14:27:07 +0200
committerAndy Wingo <wingo@igalia.com>2016-09-27 14:46:10 +0200
commite9070933bfe23412fce21237c51c6d2d86cb8681 (patch)
treea8730f2eae6a749249fbd8ae01c3cde1e1f3cf47 /gnu/packages/gobby.scm
parent22a3cff3c81d58c9d7d80c8beebec680ee90d9c3 (diff)
downloadguix-patches-e9070933bfe23412fce21237c51c6d2d86cb8681.tar
guix-patches-e9070933bfe23412fce21237c51c6d2d86cb8681.tar.gz
gnu: Add gobby.
* gnu/packages/gobby.scm (gobby): New variable.
Diffstat (limited to 'gnu/packages/gobby.scm')
-rw-r--r--gnu/packages/gobby.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/gobby.scm b/gnu/packages/gobby.scm
index 0502af799e..961028d00a 100644
--- a/gnu/packages/gobby.scm
+++ b/gnu/packages/gobby.scm
@@ -95,3 +95,37 @@
"Library that provides synced document buffers. It supports multiple
documents in one session. Obby is used by the Gobby collaborative editor.")
(license license:gpl2+)))
+
+(define-public gobby
+ (package
+ (name "gobby")
+ (version "0.4.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://releases.0x539.de/gobby/gobby-"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0w8q01lf6bcdz537b29m7rwlbc7k87b12vnpm1h6219ypvzqkgcc"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("libxml++-2" ,libxml++-2)
+ ("gnutls" ,gnutls)
+ ("gtkmm-2" ,gtkmm-2)
+ ("gtksourceview-2" ,gtksourceview-2)
+ ("libnet6" ,libnet6)
+ ("obby" ,obby)))
+ (arguments
+ ;; Required by libsigc++.
+ `(#:configure-flags '("CXXFLAGS=-std=c++11")))
+ (home-page "https://gobby.github.io/")
+ (synopsis "Collaborative editor")
+ (description
+ "Collaborative editor that supports multiple documents in one session and
+a multi-user chat. Gobby allows multiple users to edit the same document
+together over the internet in real-time.")
+ (license license:gpl2+)))