summaryrefslogtreecommitdiff
path: root/gnu/packages/gobby.scm
diff options
context:
space:
mode:
authorAndy Wingo <wingo@igalia.com>2016-09-27 14:25:56 +0200
committerAndy Wingo <wingo@igalia.com>2016-09-27 14:46:10 +0200
commitc8105e811b1f3a1f01d6942bd9ddeb8004ce30f3 (patch)
treecd2ee7a72ca3002250b7b4bb04f0a06ccf481454 /gnu/packages/gobby.scm
parentb61d9627235aa6de8f2c0adc71147b2ed7ad13a9 (diff)
downloadguix-patches-c8105e811b1f3a1f01d6942bd9ddeb8004ce30f3.tar
guix-patches-c8105e811b1f3a1f01d6942bd9ddeb8004ce30f3.tar.gz
gnu: Add libnet6.
* gnu/packages/gobby.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add new file.
Diffstat (limited to 'gnu/packages/gobby.scm')
-rw-r--r--gnu/packages/gobby.scm68
1 files changed, 68 insertions, 0 deletions
diff --git a/gnu/packages/gobby.scm b/gnu/packages/gobby.scm
new file mode 100644
index 0000000000..f1df9b4d15
--- /dev/null
+++ b/gnu/packages/gobby.scm
@@ -0,0 +1,68 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Andy Wingo <wingo@igalia.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages gobby)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix utils)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages xml))
+
+(define-public libnet6
+ (package
+ (name "libnet6")
+ (version "1.3.14")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://releases.0x539.de/net6/net6-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "088yqq60wjx3jqjlhl12893p15gl9asjpavrbhh590qzpqndhp8m"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:configure-flags
+ '("CXXFLAGS=-std=c++11") ; required by libsigc++
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'update-gnutls-api
+ (lambda _
+ (substitute* "src/encrypt.cpp"
+ ;; The GnuTLS API to set authentication and other parameters
+ ;; and priorities changed in 3.4; update to allow ANON_DH via
+ ;; the new API.
+ (("gnutls_kx_set_priority\\(session, kx_prio\\)")
+ (string-append "gnutls_priority_set_direct"
+ "(session, \"NORMAL:+ANON-DH\", NULL)"))))))))
+ (inputs
+ `(("libsigc++" ,libsigc++)
+ ("gnutls" ,gnutls)))
+ (home-page "https://gobby.github.io/")
+ (synopsis "Network access framework for IPv4/IPv6")
+ (description
+ "Library which that provides a TCP protocol abstraction for C++.")
+ (license license:lgpl2.1)))