summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-08-12 14:00:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-08-12 14:02:17 +0300
commite80a447976ce7784db1cb2dc9e99a42b58ea1b6c (patch)
tree47d9036fe373c22b3c45dcd92a3bcdaf714848e6 /gnu/packages/gnuzilla.scm
parent17c26b7ec52b21f19234eaf160036ad400071eb0 (diff)
downloadguix-patches-e80a447976ce7784db1cb2dc9e99a42b58ea1b6c.tar
guix-patches-e80a447976ce7784db1cb2dc9e99a42b58ea1b6c.tar.gz
gnu: gnuzilla: Use 'generate-all-checksums'.
* gnu/packages/gnuzilla.scm (icecat)[arguments]: During custom 'patch-cargo-checksums phase, replace call to 'generate-checksums' with call to 'generate-all-checksums'.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index ff382b2388..eec66b15c9 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
-;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 ng0 <ng0@n0.is>
@@ -743,7 +743,7 @@ from forcing GEXP-PROMISE."
;; "--with-system-png"
)
- #:imported-modules ,%cargo-utils-modules ;for `generate-checksums'
+ #:imported-modules ,%cargo-utils-modules ;for `generate-all-checksums'
#:modules ((ice-9 ftw)
(ice-9 rdelim)
@@ -843,15 +843,7 @@ from forcing GEXP-PROMISE."
(substitute* '("Cargo.lock" "servo/Cargo.lock")
(("(\"checksum .* = )\".*\"" all name)
(string-append name "\"" null-hash "\"")))
- (for-each
- (lambda (filename)
- (delete-file filename)
- (let ((dir (dirname filename)))
- (display (string-append
- "patch-cargo-checksums: generate-checksums for "
- dir "\n"))
- (generate-checksums dir)))
- (find-files "third_party/rust" ".cargo-checksum.json")))
+ (generate-all-checksums "third_party/rust"))
#t))
(add-before 'configure 'augment-CPLUS_INCLUDE_PATH
(lambda* (#:key build inputs #:allow-other-keys)