summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2021-12-11 17:26:53 +0100
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2021-12-11 17:28:59 +0100
commit8c6508b9287422c81e360e64066532b0def8963d (patch)
treebc821ef7f06acd641150141698c9b3693f0a92a8 /gnu/packages/gnuzilla.scm
parent2e28b450d5571ba25a45ffe131266695361aa189 (diff)
downloadguix-patches-8c6508b9287422c81e360e64066532b0def8963d.tar
guix-patches-8c6508b9287422c81e360e64066532b0def8963d.tar.gz
gnu: icedove: Update to 91.4.0 [fixes CVE-2021-43528].
* gnu/packages/gnuzilla.scm (icedove): Update to 91.4.0.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index bc4ef2ce45..6d9f8f44ac 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1321,11 +1321,11 @@ standards of the IceCat project.")
(cpe-version . ,(first (string-split version #\-)))))))
;; Update this together with icecat!
-(define %icedove-build-id "20211119000000") ;must be of the form YYYYMMDDhhmmss
+(define %icedove-build-id "20211207000000") ;must be of the form YYYYMMDDhhmmss
(define-public icedove
(package
(name "icedove")
- (version "91.3.2")
+ (version "91.4.0")
(source icecat-source)
(properties
`((cpe-name . "thunderbird_esr")))
@@ -1607,7 +1607,7 @@ standards of the IceCat project.")
;; in the Thunderbird release tarball. We don't use the release
;; tarball because it duplicates the Icecat sources and only adds the
;; "comm" directory, which is provided by this repository.
- ,(let ((changeset "c35def313c0c2bd0341e3e058f862f02390269c4"))
+ ,(let ((changeset "ab6dfcf3a37bf53aac1a9d632d45ee51047050bb"))
(origin
(method hg-fetch)
(uri (hg-reference
@@ -1616,7 +1616,7 @@ standards of the IceCat project.")
(file-name (string-append "thunderbird-" version "-checkout"))
(sha256
(base32
- "0rp4i353dskx065a6hskvfpf0l2qywqnivks9qc6a85h4yah4rvq")))))
+ "00zj1k3c8p66ylf9n7xp42y6kiv3h6hf8ba7bk6f8wj3hh0r2hrd")))))
("cargo" ,rust-1.51 "cargo")
("clang" ,clang)
("llvm" ,llvm)