summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-10-28 01:27:02 -0400
committerMark H Weaver <mhw@netris.org>2019-10-29 01:23:21 -0400
commit7a1b2ba54560a593eb02a3bf4d0462b66c50f2c3 (patch)
tree8e4e059ac224f4367f712a229bfee878cd5d99aa /gnu/packages/gnuzilla.scm
parenta06193603b7e7922439fc5a9d616b7ef872b8b03 (diff)
downloadguix-patches-7a1b2ba54560a593eb02a3bf4d0462b66c50f2c3.tar
guix-patches-7a1b2ba54560a593eb02a3bf4d0462b66c50f2c3.tar.gz
gnu: icecat: Update to 68.2.0-guix0-preview2.
* gnu/packages/gnuzilla.scm (%icecat-version): Update. (%icecat-build-id): New variable. (icecat-source): Update gnuzilla repo commit and hash. (icecat)[arguments]: In the custom 'configure' phase, set the MOZ_BUILD_DATE environment variable to the value of %icecat-build-id. * gnu/packages/patches/icecat-gnuzilla-fixes.patch: Remove changes that are now in the upstream repository. Add more pending changes, including disabling the MOZ_SERVICES_HEALTHREPORT and MOZ_BLOCK_PROFILE_DOWNGRADE build flags, fixing a problem that prevented MOZ_DATA_REPORTING from being disabled, and fixes to the branding. * gnu/packages/patches/icecat-makeicecat.patch: Adapt to upstream changes, and changes in icecat-gnuzilla-fixes.patch. Remove a hunk that disabled rewrites to aboutRights.dtd in the l10n directory.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 3902f490d0..16d3fe5db9 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -550,7 +550,8 @@ from forcing GEXP-PROMISE."
#:system system
#:guile-for-build guile)))
-(define %icecat-version "68.2.0-guix0-preview1")
+(define %icecat-version "68.2.0-guix0-preview2")
+(define %icecat-build-id "20191028000000") ;must be of the form YYYYMMDDhhmmss
;; 'icecat-source' is a "computed" origin that generates an IceCat tarball
;; from the corresponding upstream Firefox ESR tarball, using the 'makeicecat'
@@ -576,7 +577,7 @@ from forcing GEXP-PROMISE."
(upstream-icecat-base-version "68.1.0") ; maybe older than base-version
;;(gnuzilla-commit (string-append "v" upstream-icecat-base-version))
- (gnuzilla-commit "395cc0798600cde44a30abaa3f5d08ce8b68f782")
+ (gnuzilla-commit "aa7ab9483a64c43e77736917dd83841ccc437300")
(gnuzilla-source
(origin
(method git-fetch)
@@ -586,7 +587,7 @@ from forcing GEXP-PROMISE."
(file-name (git-file-name "gnuzilla" upstream-icecat-base-version))
(sha256
(base32
- "1ll3j2kpsfp1f9dxy67fay1cidsng02l8a3a23wdjqkxgrg1cf4g"))))
+ "03jygq1zna621y0ba6370cff4v2g9l57g3015y3vxbahnmzn9msa"))))
(gnuzilla-fixes-patch
(local-file (search-patch "icecat-gnuzilla-fixes.patch")))
@@ -1016,6 +1017,7 @@ from forcing GEXP-PROMISE."
(setenv "CONFIG_SHELL" bash)
(setenv "AUTOCONF" (which "autoconf")) ; must be autoconf-2.13
(setenv "CC" "gcc") ; apparently needed when Stylo is enabled
+ (setenv "MOZ_BUILD_DATE" ,%icecat-build-id) ; avoid timestamp
(mkdir "../build")
(chdir "../build")
(format #t "build directory: ~s~%" (getcwd))