summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2022-05-05 23:09:48 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2022-05-05 23:09:48 +0200
commit34dbbb917251be0adf40bd9db2a8651779eace0e (patch)
tree226a3786b232f42746a96fc61e697fd125dcb8dd /gnu/packages/gnuzilla.scm
parentd809e71df220e2be40a7cee32316ca3f20da6768 (diff)
downloadguix-patches-34dbbb917251be0adf40bd9db2a8651779eace0e.tar
guix-patches-34dbbb917251be0adf40bd9db2a8651779eace0e.tar.gz
gnu: icedove: Update to 91.9.0 [fixes CVE-2022-1520].
* gnu/packages/gnuzilla.scm (icedove): Update to 91.9.0.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 91f8d3eb27..96c51cf8db 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1338,11 +1338,11 @@ standards of the IceCat project.")
(cpe-version . ,(first (string-split version #\-)))))))
;; Update this together with icecat!
-(define %icedove-build-id "20220405000000") ;must be of the form YYYYMMDDhhmmss
+(define %icedove-build-id "20220503000000") ;must be of the form YYYYMMDDhhmmss
(define-public icedove
(package
(name "icedove")
- (version "91.8")
+ (version "91.9.0")
(source icecat-source)
(properties
`((cpe-name . "thunderbird_esr")))
@@ -1628,7 +1628,7 @@ standards of the IceCat project.")
;; in the Thunderbird release tarball. We don't use the release
;; tarball because it duplicates the Icecat sources and only adds the
;; "comm" directory, which is provided by this repository.
- ,(let ((changeset "525d4941f4870a56f714af775b7d7bc18175021d"))
+ ,(let ((changeset "8b44d29de6525d6379f163f50c1a900d4540ef1b"))
(origin
(method hg-fetch)
(uri (hg-reference
@@ -1637,7 +1637,7 @@ standards of the IceCat project.")
(file-name (string-append "thunderbird-" version "-checkout"))
(sha256
(base32
- "1kq6564bjzd80nsggyih4ypbkf35p32j5akaq589sm3xbjgd1zq6")))))
+ "1k7zy53il3i4k2k7mc33j0wsgpjrsghmmj6afs14hk9j95byvayy")))))
("cargo" ,rust "cargo")
("clang" ,clang-11)
("llvm" ,llvm-11)