summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-13 14:12:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:10 -0400
commit34d705ff93f077291fc43a6a3d9ceae4d98f14a8 (patch)
tree0058a91df098b98eaa17b0ace4fbdf971da9e534 /gnu/packages/gnuzilla.scm
parent5e25a69e6e3733ad8845d1b187940877deba7750 (diff)
downloadguix-patches-34d705ff93f077291fc43a6a3d9ceae4d98f14a8.tar
guix-patches-34d705ff93f077291fc43a6a3d9ceae4d98f14a8.tar.gz
gnu: icedove: Delete obsolete Python 2 input.
* gnu/packages/gnuzilla.scm (icedove)[native-inputs]: Replace python-2 with python-wrapper. Delete python. [phases]: Delete trailing #t.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm24
1 files changed, 8 insertions, 16 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 0c64c44adf..7f8cbe1120 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1000,8 +1000,7 @@ standards of the IceCat project.")
(mkdir "comm")
(copy-recursively (assoc-ref inputs "thunderbird-sources")
"comm")
- (delete-file "sourcestamp.txt")
- #t))
+ (delete-file "sourcestamp.txt")))
(add-after 'patch-source-shebangs 'patch-cargo-checksums
(lambda _
(use-modules (guix build cargo-utils))
@@ -1014,16 +1013,14 @@ standards of the IceCat project.")
(find-files "." "Cargo.lock$"))
(for-each generate-all-checksums
'("third_party/rust"
- "toolkit/library/rust")))
- #t))
+ "toolkit/library/rust")))))
;; Fixes issue where each installation directory generates its own profile.
;; See e.g. https://trac.torproject.org/projects/tor/ticket/31457
(add-after 'patch-source-shebangs 'fix-profile-setting
(lambda _
(substitute* "comm/mail/moz.configure"
(("MOZ_DEDICATED_PROFILES, True")
- "MOZ_DEDICATED_PROFILES, False"))
- #t))
+ "MOZ_DEDICATED_PROFILES, False"))))
(add-after 'prepare-thunderbird-sources 'rename-to-icedove
(lambda _
(substitute* "comm/mail/confvars.sh"
@@ -1086,8 +1083,7 @@ standards of the IceCat project.")
(("(pref\\(\"extensions.systemAddon.update.enabled\").*" _ m)
(string-append m ", false);"))
(("(pref\\(\"lightweightThemes.update.enabled\").*" _ m)
- (string-append m ", false);")))
- #t))
+ (string-append m ", false);")))))
(add-after 'build 'neutralize-store-references
(lambda _
;; Mangle the store references to compilers & other build tools in
@@ -1103,8 +1099,7 @@ standards of the IceCat project.")
(string-append store
(string-take hash 8)
"<!-- Guix: not a runtime dependency -->"
- (string-drop hash 8))))
- #t))
+ (string-drop hash 8))))))
(delete 'bootstrap)
(replace 'configure
(lambda* (#:key inputs outputs configure-flags #:allow-other-keys)
@@ -1206,8 +1201,7 @@ standards of the IceCat project.")
[Desktop Action ComposeMessage]~@
Name=Write new message~@
Exec=~@*~a/bin/icedove -compose~%"
- out))))
- #t))
+ out))))))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -1220,8 +1214,7 @@ standards of the IceCat project.")
(eudev-lib (string-append eudev "/lib")))
(wrap-program (car (find-files lib "^icedove$"))
`("XDG_DATA_DIRS" prefix (,gtk-share))
- `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib ,eudev-lib)))
- #t))))))
+ `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib ,eudev-lib)))))))))
(inputs
`(("bzip2" ,bzip2)
("cairo" ,cairo)
@@ -1285,8 +1278,7 @@ standards of the IceCat project.")
("node" ,node)
("perl" ,perl)
("pkg-config" ,pkg-config)
- ("python" ,python)
- ("python2" ,python-2.7)
+ ("python" ,python-wrapper)
("rust" ,rust)
("rust-cbindgen" ,rust-cbindgen-0.19)
("which" ,which)