summaryrefslogtreecommitdiff
path: root/gnu/packages/gnustep.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2016-10-23 13:50:05 -0400
committerKei Kebreau <kei@openmailbox.org>2016-12-09 22:10:06 -0500
commitfdb552bbd44e35d335ee1d430ffe5b0fc4bc237e (patch)
tree8027a975eb71553ef96716e73e44c547e4d5c836 /gnu/packages/gnustep.scm
parenta225db529337035b159b2b75714ee18753c26d21 (diff)
downloadguix-patches-fdb552bbd44e35d335ee1d430ffe5b0fc4bc237e.tar
guix-patches-fdb552bbd44e35d335ee1d430ffe5b0fc4bc237e.tar.gz
gnu: windowmaker: Fix invocation of 'wmsetbg'.
* gnu/packages/gnustep.scm (windowmaker)[arguments]: Add substitution of 40-character limit with a 107-character limit.
Diffstat (limited to 'gnu/packages/gnustep.scm')
-rw-r--r--gnu/packages/gnustep.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
index 6c365cbbc4..8f72bb3253 100644
--- a/gnu/packages/gnustep.scm
+++ b/gnu/packages/gnustep.scm
@@ -60,7 +60,13 @@
(string-append "\"" bin "/wmaker.inst")))
(substitute* '("src/defaults.c" "WPrefs.app/Menu.c")
(("\"wmsetbg")
- (string-append "\"" bin "/wmsetbg")))))
+ (string-append "\"" bin "/wmsetbg")))
+ ;; Add enough cells to the command character array to
+ ;; allow passing our large path to the wmsetbg binary.
+ ;; The path to wmsetbg in Guix requires 67 extra characters.
+ (substitute* "src/defaults.c"
+ (("len = strlen\\(text\\) \\+ 40;")
+ (string-append "len = strlen(text) + 107;")))))
(alist-cons-after
'install 'wrap
(lambda* (#:key outputs #:allow-other-keys)