summaryrefslogtreecommitdiff
path: root/gnu/packages/gnustep.scm
diff options
context:
space:
mode:
authorKei Yamashita <kei@openmailbox.org>2016-04-06 13:50:36 -0400
committerLeo Famulari <leo@famulari.name>2016-04-06 14:51:27 -0400
commitbd688698b682dcec68ed004f262e71850ee7b528 (patch)
tree4bee46211658041e3a23bd75bcf20866fd3b7b95 /gnu/packages/gnustep.scm
parent4323a5f0fd50ac247c835757546e3496b91300db (diff)
downloadguix-patches-bd688698b682dcec68ed004f262e71850ee7b528.tar
guix-patches-bd688698b682dcec68ed004f262e71850ee7b528.tar.gz
gnu: Add wmcpuload.
* gnu/packages/gnustep.scm (wmcpuload): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/gnustep.scm')
-rw-r--r--gnu/packages/gnustep.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
index 8ca32e47cf..8c43085eaf 100644
--- a/gnu/packages/gnustep.scm
+++ b/gnu/packages/gnustep.scm
@@ -152,3 +152,32 @@ graph), and battery status (high - green, low - yellow, or critical - red).")
"WMND is a dockapp for monitoring network interfaces under WindowMaker and
other compatible window managers.")
(license gpl2+)))
+
+(define-public wmcpuload
+ (package
+ (name "wmcpuload")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://debian/pool/main/w/wmcpuload/"
+ name "_" version ".orig.tar.gz"))
+ (sha256
+ (base32
+ "0irlns4cvxy2mnicx75bya166hdxq7h8bphds3ligijcl9fzgs6n"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("libxpm" ,libxpm)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://windowmaker.org/dockapps/?name=wmcpuload")
+ (synopsis "Monitor CPU usage")
+ (description
+ "Wmcpuload displays the current CPU usage, expressed as a percentile and a
+chart, and has an LCD look-alike user interface. The back-light may be turned
+on and off by clicking the mouse button over the application. If the CPU usage
+hits a certain threshold, an alarm-mode will alert you by turning back-light
+on.")
+ (license gpl2+)))