summaryrefslogtreecommitdiff
path: root/gnu/packages/gnustep.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-03-14 02:14:32 -0400
committerLeo Famulari <leo@famulari.name>2017-03-14 12:10:16 -0400
commit962cbb24c5a9beea5c6bda0e7662bead7cb2c4ca (patch)
treee1964efc6161df1b4cf11bb873bdc6978c90d51d /gnu/packages/gnustep.scm
parent8cac5bca126fe9d1c7557cd64a3dc4332d41e664 (diff)
downloadguix-patches-962cbb24c5a9beea5c6bda0e7662bead7cb2c4ca.tar
guix-patches-962cbb24c5a9beea5c6bda0e7662bead7cb2c4ca.tar.gz
gnu: windowmaker: Use modify-phases syntax.
* gnu/packages/gnustep.scm (windowmaker)[arguments]: Use modify-phases.
Diffstat (limited to 'gnu/packages/gnustep.scm')
-rw-r--r--gnu/packages/gnustep.scm61
1 files changed, 30 insertions, 31 deletions
diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
index 6081549d7d..6e729165c9 100644
--- a/gnu/packages/gnustep.scm
+++ b/gnu/packages/gnustep.scm
@@ -46,37 +46,36 @@
"12p8kljqgx5hnic0zvs5mxwp7kg21sb6qjagb2qw8ydvf5amrgwx"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-cons-before
- 'configure 'pre-configure
- (lambda* (#:key outputs #:allow-other-keys)
- ;; 'wmaker' wants to invoke 'wmaker.inst' the first time,
- ;; and the 'wmsetbg', so make sure it uses the right ones.
- ;; We can't use a wrapper here because that would pollute
- ;; $PATH in the whole session.
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (substitute* "src/main.c"
- (("\"wmaker\\.inst")
- (string-append "\"" bin "/wmaker.inst")))
- (substitute* '("src/defaults.c" "WPrefs.app/Menu.c")
- (("\"wmsetbg")
- (string-append "\"" bin "/wmsetbg")))
- ;; Add enough cells to the command character array to
- ;; allow passing our large path to the wmsetbg binary.
- ;; The path to wmsetbg in Guix requires 67 extra characters.
- (substitute* "src/defaults.c"
- (("len = strlen\\(text\\) \\+ 40;")
- (string-append "len = strlen(text) + 107;")))))
- (alist-cons-after
- 'install 'wrap
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- ;; In turn, 'wmaker.inst' wants to invoke 'wmmenugen'
- ;; etc., so make sure everything is in $PATH.
- (wrap-program (string-append bin "/wmaker.inst")
- `("PATH" ":" prefix (,bin)))))
- %standard-phases))))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'pre-configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; 'wmaker' wants to invoke 'wmaker.inst' the first time,
+ ;; and the 'wmsetbg', so make sure it uses the right ones.
+ ;; We can't use a wrapper here because that would pollute
+ ;; $PATH in the whole session.
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (substitute* "src/main.c"
+ (("\"wmaker\\.inst")
+ (string-append "\"" bin "/wmaker.inst")))
+ (substitute* '("src/defaults.c" "WPrefs.app/Menu.c")
+ (("\"wmsetbg")
+ (string-append "\"" bin "/wmsetbg")))
+ ;; Add enough cells to the command character array to
+ ;; allow passing our large path to the wmsetbg binary.
+ ;; The path to wmsetbg in Guix requires 67 extra characters.
+ (substitute* "src/defaults.c"
+ (("len = strlen\\(text\\) \\+ 40;")
+ (string-append "len = strlen(text) + 107;"))))))
+ (add-after 'install 'wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ ;; In turn, 'wmaker.inst' wants to invoke 'wmmenugen'
+ ;; etc., so make sure everything is in $PATH.
+ (wrap-program (string-append bin "/wmaker.inst")
+ `("PATH" ":" prefix (,bin)))))))))
(inputs
`(("libxmu" ,libxmu)
("libxft" ,libxft)