summaryrefslogtreecommitdiff
path: root/gnu/packages/gnustep.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-15 23:30:03 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-16 11:11:40 +0100
commit93710d861f5987b7e87221d39e568afd86357c80 (patch)
treef98dc56d16cc57be3e3380f62438949b09a6aa15 /gnu/packages/gnustep.scm
parent340978d7b054dcde6c3334267b40a8293eb0ce85 (diff)
downloadguix-patches-93710d861f5987b7e87221d39e568afd86357c80.tar
guix-patches-93710d861f5987b7e87221d39e568afd86357c80.tar.gz
gnu: wmbattery: Update to 2.51.
* gnu/packages/gnustep.scm (wmbattery): Update to 2.51. [source]: Remove upstreamed bugfix snippet.
Diffstat (limited to 'gnu/packages/gnustep.scm')
-rw-r--r--gnu/packages/gnustep.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
index 0e9cf230f2..e1aa6d007a 100644
--- a/gnu/packages/gnustep.scm
+++ b/gnu/packages/gnustep.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -154,7 +155,7 @@ interface. It is fast, feature rich, easy to configure, and easy to use.")
(define-public wmbattery
(package
(name "wmbattery")
- (version "2.50")
+ (version "2.51")
(source (origin
(method url-fetch)
(uri (string-append
@@ -162,15 +163,7 @@ interface. It is fast, feature rich, easy to configure, and easy to use.")
version ".orig.tar.gz"))
(sha256
(base32
- "0hi6bivv3xd2k68w08krndfl68wdx7nmc2wjzsmcd4q3qgwgyk44"))
- (modules '((guix build utils)))
- (snippet
- ;; Fix memory leak:
- ;; <https://lists.gnu.org/archive/html/guix-devel/2016-05/msg00466.html>.
- '(substitute* "upower.c"
- (("up = up_client_new\\(\\);")
- (string-append "if (!up)\n"
- " up = up_client_new();"))))))
+ "084a3irxbmgms4bqaga80mlx9wgvlkx6d2w0ns939yrpfzg87laj"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no "check" target