summaryrefslogtreecommitdiff
path: root/gnu/packages/gnustep.scm
diff options
context:
space:
mode:
authorKei Yamashita <kei@openmailbox.org>2016-05-17 18:52:16 -0400
committerLudovic Courtès <ludo@gnu.org>2016-05-18 23:41:03 +0200
commit64851f4a23f133901f5086dcd5ae4d4c0687164c (patch)
tree1789103429156193b80f34e7047cc6fb69fec75f /gnu/packages/gnustep.scm
parent65e46ca0ede8e7a150215f6bfd9ea756c8239085 (diff)
downloadguix-patches-64851f4a23f133901f5086dcd5ae4d4c0687164c.tar
guix-patches-64851f4a23f133901f5086dcd5ae4d4c0687164c.tar.gz
gnu: wmbattery: Fix UPower-related memory leak.
* gnu/packages/gnustep.scm (wmbattery)[source](snippet): New field. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnustep.scm')
-rw-r--r--gnu/packages/gnustep.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
index 31fca5b504..30574fca18 100644
--- a/gnu/packages/gnustep.scm
+++ b/gnu/packages/gnustep.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016 Kei Yamashita <kei@openmailbox.org>
+;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -101,7 +101,15 @@ interface. It is fast, feature rich, easy to configure, and easy to use.")
version ".orig.tar.gz"))
(sha256
(base32
- "0hi6bivv3xd2k68w08krndfl68wdx7nmc2wjzsmcd4q3qgwgyk44"))))
+ "0hi6bivv3xd2k68w08krndfl68wdx7nmc2wjzsmcd4q3qgwgyk44"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Fix memory leak:
+ ;; <https://lists.gnu.org/archive/html/guix-devel/2016-05/msg00466.html>.
+ '(substitute* "upower.c"
+ (("up = up_client_new\\(\\);")
+ (string-append "if (!up)\n"
+ " up = up_client_new();"))))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no "check" target