summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-08-28 17:06:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-08-28 17:24:58 +0300
commite184de574843e0f374ecae975b3459c52abf0f8f (patch)
tree41766db091d097a906eec6551cedfc37184c5793 /gnu/packages/gnupg.scm
parent174fbd5f3b2f286cf06e58787853db6b8f0f5b35 (diff)
downloadguix-patches-e184de574843e0f374ecae975b3459c52abf0f8f.tar
guix-patches-e184de574843e0f374ecae975b3459c52abf0f8f.tar.gz
gnu: gnupg: Update to 2.2.0.
* gnu/packages/gnupg.scm (gnupg): Update to 2.2.0. [arguments]: Add flag to run more tests.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index fd850c0469..872e98f44e 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -203,14 +203,14 @@ compatible to GNU Pth.")
(define-public gnupg
(package
(name "gnupg")
- (version "2.1.23")
+ (version "2.2.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnupg/gnupg/gnupg-" version
".tar.bz2"))
(sha256
(base32
- "0xqd5nm4j3w9lwk35vg57gl2i8bfkmx7d24i44gkbscm2lwpci59"))))
+ "1rj538kp3wsdq7rhl8sy1wpwhlsbxcch0cwk64kgz8gpw05lllfl"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -232,7 +232,8 @@ compatible to GNU Pth.")
`(#:configure-flags '(;; Otherwise, the test suite looks for the `gpg`
;; executable in its installation directory in
;; /gnu/store before it has been installed.
- "--enable-gnupg-builddir-envvar")
+ "--enable-gnupg-builddir-envvar"
+ "--enable-all-tests")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-paths