summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-05-06 14:20:13 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-05-06 15:47:20 +0200
commitdf9f62899150c491b07754154b20a43bacdf7cab (patch)
treec824643255631b9e47465bf3470d0b311583f566 /gnu/packages/gnupg.scm
parent296551a2e9310d4a030ee49530e9367e73aaeecf (diff)
downloadguix-patches-df9f62899150c491b07754154b20a43bacdf7cab.tar
guix-patches-df9f62899150c491b07754154b20a43bacdf7cab.tar.gz
gnu: gpgme: Update to 1.11.1.
* gnu/packages/gnupg.scm (libgpg-error-1.31): New public variable. (gpgme): Update to 1.11.1. [propagated-inputs]: Change LIBGPG-ERROR to LIBGPG-ERROR-1.31.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm21
1 files changed, 18 insertions, 3 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index f397482ab0..13e700ccb1 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -90,6 +91,20 @@ Daemon and possibly more in the future.")
(properties '((ftp-server . "ftp.gnupg.org")
(ftp-directory . "/gcrypt/libgpg-error")))))
+;; Some packages (e.g. GPGME) require a newer libgpg-error to deal with
+;; error codes from recent GnuPG. Remove this in the next rebuild cycle.
+(define-public libgpg-error-1.31
+ (package
+ (inherit libgpg-error)
+ (version "1.31")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnupg/libgpg-error/libgpg-error-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1vx4nw6rxh2biy3h8n96fyr86q29h8gjl6837437i51jr4isil20"))))))
+
(define-public libgcrypt
(package
(name "libgcrypt")
@@ -359,7 +374,7 @@ libskba (working with X.509 certificates and CMS data).")
(define-public gpgme
(package
(name "gpgme")
- (version "1.10.0")
+ (version "1.11.1")
(source
(origin
(method url-fetch)
@@ -367,13 +382,13 @@ libskba (working with X.509 certificates and CMS data).")
".tar.bz2"))
(sha256
(base32
- "14q619lxbk64vz7lih5gjb928qm28jrnn1h3yhsrrff3jw8yv3qs"))))
+ "0vxx5xaag3rhp4g2arp5qm77gvz4kj0m3hnpvhkdvqyjfhbi26rd"))))
(build-system gnu-build-system)
(native-inputs
`(("gnupg" ,gnupg)))
(propagated-inputs
;; Needs to be propagated because gpgme.h includes gpg-error.h.
- `(("libgpg-error" ,libgpg-error)))
+ `(("libgpg-error" ,libgpg-error-1.31)))
(inputs
`(("libassuan" ,libassuan)))
(home-page "https://www.gnupg.org/related_software/gpgme/")