summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-01-27 22:33:07 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-01-27 22:37:33 +0100
commitcd80e11b9555f6d0a9f3413613eeea319ce6c6c3 (patch)
tree352e102f508d8b35dbedefa1128373fd3ad28066 /gnu/packages/gnupg.scm
parentaee72ed1c6ee75fb8fe8736e14596a429d023509 (diff)
downloadguix-patches-cd80e11b9555f6d0a9f3413613eeea319ce6c6c3.tar
guix-patches-cd80e11b9555f6d0a9f3413613eeea319ce6c6c3.tar.gz
gnu: pinentry-tty: Update to 1.1.1.
* gnu/packages/gnupg.scm (pinentry-tty): Update to 1.1.1. (pinentry-efl)[source]: Remove patch. * gnu/packages/patches/pinentry-efl.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 4db7b4ca86..a6e75f0e38 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -775,14 +775,14 @@ including tools for signing keys, keyring analysis, and party preparation.
(define-public pinentry-tty
(package
(name "pinentry-tty")
- (version "1.1.0")
+ (version "1.1.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnupg/pinentry/pinentry-"
version ".tar.bz2"))
(sha256
(base32
- "0w35ypl960pczg5kp6km3dyr000m1hf0vpwwlh72jjkjza36c1v8"))))
+ "0zx5vg6wws2sp2yxwi01b8i1pnsqkydncpj7x0p8xl9y05ja04nd"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--enable-pinentry-tty")))
@@ -860,10 +860,6 @@ passphrase when @code{gpg} is run and needs it.")))
(package
(inherit pinentry-tty)
(name "pinentry-efl")
- (source
- (origin
- (inherit (package-source pinentry-tty))
- (patches (search-patches "pinentry-efl.patch"))))
(arguments
'(#:configure-flags '("--enable-pinentry-efl"
"--enable-fallback-curses")