summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-08 09:17:51 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-08 09:17:51 +0300
commitc9a6c0c6724ef5188bb31b7ff3496798bd955707 (patch)
tree854155ffd0709188f67b1d492f180567a02be625 /gnu/packages/gnupg.scm
parentd27afcc6ab5bec87e275e2ee73b61558371d7845 (diff)
downloadguix-patches-c9a6c0c6724ef5188bb31b7ff3496798bd955707.tar
guix-patches-c9a6c0c6724ef5188bb31b7ff3496798bd955707.tar.gz
gnu: pinentry: Enable curses fallback.
* gnu/packages/gnupg.scm (pinentry-gtk2, pinentry-gnome3, pinentry-qt, pinentry-efl)[arguments]: Add configure-flag for fallback curses mode.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 2f663b3362..c0f827b7e3 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -868,6 +868,8 @@ enter a passphrase when required by @code{gpg} or other software.")))
(package
(inherit pinentry-tty)
(name "pinentry-gtk2")
+ (arguments
+ `(#:configure-flags '("--enable-fallback-curses")))
(inputs
`(("gtk+" ,gtk+-2)
("glib" ,glib)
@@ -886,7 +888,8 @@ passphrase when @code{gpg} is run and needs it.")))
("glib" ,glib)
,@(package-inputs pinentry-tty)))
(arguments
- `(#:configure-flags '("--enable-pinentry-gnome3")))
+ `(#:configure-flags '("--enable-pinentry-gnome3"
+ "--enable-fallback-curses")))
(description
"Pinentry provides a console and a GUI designed for use with GNOME@tie{}3
that allows users to enter a passphrase when required by @code{gpg} or other
@@ -896,6 +899,8 @@ software.")))
(package
(inherit pinentry-tty)
(name "pinentry-qt")
+ (arguments
+ `(#:configure-flags '("--enable-fallback-curses")))
(inputs
`(("qtbase" ,qtbase)
,@(package-inputs pinentry-tty)))
@@ -912,7 +917,8 @@ passphrase when @code{gpg} is run and needs it.")))
(inherit (package-source pinentry-tty))
(patches (search-patches "pinentry-efl.patch"))))
(arguments
- '(#:configure-flags '("--enable-pinentry-efl")
+ '(#:configure-flags '("--enable-pinentry-efl"
+ "--enable-fallback-curses")
#:phases
(modify-phases %standard-phases
(replace 'bootstrap