summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-02-06 13:03:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-02-06 13:03:26 +0100
commitba88eea2b3a8a33ecd7fc0ec64e3917c6c2fe21d (patch)
tree75c68e44d3d76440f416552711b1a47ec83e411e /gnu/packages/gnupg.scm
parentf380f9d55e6757c242acf6c71c4a3ccfcdb066b2 (diff)
parent4aeb7f34c948f32363f2ae29c6942c6328df758c (diff)
downloadguix-patches-ba88eea2b3a8a33ecd7fc0ec64e3917c6c2fe21d.tar
guix-patches-ba88eea2b3a8a33ecd7fc0ec64e3917c6c2fe21d.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm216
1 files changed, 115 insertions, 101 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 360f28a1bf..2ef165946e 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -4,8 +4,8 @@
;;; Copyright © 2014, 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
-;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016, 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2016 Christopher Baines <mail@cbaines.net>
@@ -49,16 +49,17 @@
#:use-module (gnu packages perl-check)
#:use-module (gnu packages pth)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
#:use-module (gnu packages compression)
- #:use-module (gnu packages databases)
#:use-module (gnu packages gtk)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages security-token)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages swig)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
@@ -136,7 +137,7 @@ generation.")
(define-public libassuan
(package
(name "libassuan")
- (version "2.5.1")
+ (version "2.5.2")
(source
(origin
(method url-fetch)
@@ -144,7 +145,7 @@ generation.")
version ".tar.bz2"))
(sha256
(base32
- "0jb4nb4nrjr949gd3lw8lh4v5d6qigxaq6xwy24w5apjnhvnrya7"))))
+ "1rw8nw6fx6ppxga6m4cqcp898lnlzf7vn3s5c2lzfxg3fzr1nswq"))))
(build-system gnu-build-system)
(propagated-inputs
`(("libgpg-error" ,libgpg-error)
@@ -222,14 +223,14 @@ compatible to GNU Pth.")
(define-public gnupg
(package
(name "gnupg")
- (version "2.2.11")
+ (version "2.2.12")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnupg/gnupg/gnupg-" version
".tar.bz2"))
(sha256
(base32
- "1ncwqjhcxh46fgkp84g2lhf91amcha7abk6wdm1kagzm7q93wv29"))))
+ "1jw282iy27j1qygym52aa44zxy7ly4bdadhd628hwr4q9j5hy0yv"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -367,7 +368,7 @@ libskba (working with X.509 certificates and CMS data).")
(define-public gpgme
(package
(name "gpgme")
- (version "1.11.1")
+ (version "1.12.0")
(source
(origin
(method url-fetch)
@@ -375,7 +376,16 @@ libskba (working with X.509 certificates and CMS data).")
".tar.bz2"))
(sha256
(base32
- "0vxx5xaag3rhp4g2arp5qm77gvz4kj0m3hnpvhkdvqyjfhbi26rd"))))
+ "1n4c1q2ls7sqx1vpr3p5n8vbjkw6kqp8jxqa28p0x9j36wf9bp5l"))
+ ;; One test fails because the conflict keys have expired. See
+ ;; https://dev.gnupg.org/T3815
+ (patches (list (origin
+ (method url-fetch)
+ (uri "https://dev.gnupg.org/rM66376f3e206a1aa791d712fb8577bb3490268f60?diff=1")
+ (file-name "gpgme-fix-conflict-test-keys.patch")
+ (sha256
+ (base32
+ "0j718iy5a9fhkrfs4gzrnm4ggi163prqf1i8lfmqczswvz88zfly")))))))
(build-system gnu-build-system)
(native-inputs
`(("gnupg" ,gnupg)))
@@ -470,16 +480,23 @@ interface (FFI) of Guile.")
(define-public python-gpg
(package
(name "python-gpg")
- (version "1.8.0")
+ (version "1.10.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "gpg" version))
(sha256
(base32
- "1x74i6q713c0bckls7rdm8kgsmllf9qvy9x62jghszlhgjkyh9nd"))))
+ "1ji3ynhp36m1ccx7bmaq75dhij9frpn19v9mpi4aajn8csl194il"))))
(build-system python-build-system)
(arguments
- '(#:tests? #f)) ; No test suite.
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-environment
+ (lambda _
+ (substitute* "setup.py"
+ (("cc") (which "gcc")))
+ #t)))
+ #:tests? #f)) ; No test suite.
(inputs
`(("gpgme" ,gpgme)))
(native-inputs
@@ -514,11 +531,9 @@ distributed separately.")
`(#:phases
(modify-phases %standard-phases
(add-before 'build 'make-build
- (lambda _
- (zero? (system* "make" "build"))))
+ (lambda _ (invoke "make" "build")))
(replace 'check
- (lambda _
- (zero? (system* "make" "check")))))))
+ (lambda _ (invoke "make" "check"))))))
(build-system python-build-system)
(native-inputs
`(("gnupg" ,gnupg-1)))
@@ -653,87 +668,86 @@ PGP keysigning parties.")
(home-page "https://www.phildev.net/pius/index.shtml")))
(define-public signing-party
- ;; Upstream moved from alioth.debian.org to salsa.debian.org but the
- ;; automatic svn import did not preserve tags apparently, so there's no real
- ;; version number.
- (let ((commit "d6f2296325605ee96ddf9f5b156e5e3f667a6df3")
- (revision "0"))
- (package
- (name "signing-party")
- (version (git-version "2.6" revision commit))
- (home-page "https://salsa.debian.org/stappers/pgp-tools")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit commit)))
- (sha256
- (base32
- "00f7zasbwcbjzd92br2j10pyjxv0aw1qb4540qfz2dxzxgmdscrz"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("autoconf" ,autoconf-wrapper)
- ("automake" ,automake)))
- (inputs `(("perl" ,perl)
- ("perl-text-template" ,perl-text-template)
- ("perl-mime-tools" ,perl-mime-tools)
- ("perl-gnupg-interface" ,perl-gnupg-interface)
- ("perl-net-idn-encode" ,perl-net-idn-encode)
- ("libmd" ,libmd)))
- (arguments
- `(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (substitute* "keyanalyze/Makefile"
- (("LDLIBS") (string-append "CC=" (which "gcc") "\nLDLIBS")))
- (substitute* "keyanalyze/Makefile"
- (("\\./configure") (string-append "./configure --prefix=" out)))
- (substitute* "gpgwrap/Makefile"
- (("\\} clean")
- (string-append "} clean\ninstall:\n\tinstall -D bin/gpgwrap "
- out "/bin/gpgwrap\n")))
- (substitute* '("gpgsigs/Makefile" "keyanalyze/Makefile"
- "keylookup/Makefile" "sig2dot/Makefile"
- "springgraph/Makefile")
- (("/usr") out))
- (setenv "CONFIG_SHELL" (which "sh")))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys #:rest args)
- (let ((out (assoc-ref outputs "out"))
- (install (assoc-ref %standard-phases 'install)))
- (apply install args)
- (for-each
- (lambda (dir file)
- (copy-file (string-append dir "/" file)
- (string-append out "/bin/" file)))
- '("caff" "caff" "caff" "gpgdir" "gpg-key2ps"
- "gpglist" "gpg-mailkeys" "gpgparticipants")
- '("caff" "pgp-clean" "pgp-fixkey" "gpgdir" "gpg-key2ps"
- "gpglist" "gpg-mailkeys" "gpgparticipants"))
- (for-each
- (lambda (dir file)
- (copy-file (string-append dir "/" file)
- (string-append out "/share/man/man1/" file)))
- '("caff" "caff" "caff" "gpgdir"
- "gpg-key2ps" "gpglist" "gpg-mailkeys"
- "gpgparticipants" "gpgsigs" "gpgwrap/doc"
- "keyanalyze" "keyanalyze/pgpring" "keyanalyze")
- '("caff.1" "pgp-clean.1" "pgp-fixkey.1" "gpgdir.1"
- "gpg-key2ps.1" "gpglist.1" "gpg-mailkeys.1"
- "gpgparticipants.1" "gpgsigs.1" "gpgwrap.1"
- "process_keys.1" "pgpring.1" "keyanalyze.1")))))
- (add-after 'install 'wrap-programs
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out")))
- (wrap-program
- (string-append out "/bin/caff")
- `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB"))))))))))
- (synopsis "Collection of scripts for simplifying gnupg key signing")
- (description
- "Signing-party is a collection for all kinds of PGP/GnuPG related things,
+ (package
+ (name "signing-party")
+ (version "2.7")
+ (home-page "https://salsa.debian.org/debian/signing-party")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1gx9017wag4bgc0h7kca9n3jwwdm7z77yv3viayhg62flbwkvbgb"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf-wrapper)
+ ("automake" ,automake)))
+ (inputs `(("perl" ,perl)
+ ("perl-text-template" ,perl-text-template)
+ ("perl-mime-tools" ,perl-mime-tools)
+ ("perl-gnupg-interface" ,perl-gnupg-interface)
+ ("perl-net-idn-encode" ,perl-net-idn-encode)
+ ("libmd" ,libmd)))
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "keyanalyze/Makefile"
+ (("LDLIBS") (string-append "CC=" (which "gcc") "\nLDLIBS")))
+ (substitute* "keyanalyze/Makefile"
+ (("\\./configure") (string-append "./configure --prefix=" out)))
+ (substitute* "gpgwrap/Makefile"
+ (("\\} clean")
+ (string-append "} clean\ninstall:\n\tinstall -D bin/gpgwrap "
+ out "/bin/gpgwrap\n")))
+ (substitute* '("gpgsigs/Makefile" "keyanalyze/Makefile"
+ "keylookup/Makefile" "sig2dot/Makefile"
+ "springgraph/Makefile")
+ (("/usr") out))
+ (setenv "CONFIG_SHELL" (which "sh")))
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys #:rest args)
+ (let ((out (assoc-ref outputs "out"))
+ (install (assoc-ref %standard-phases 'install)))
+ (apply install args)
+ (for-each
+ (lambda (dir file)
+ (copy-file (string-append dir "/" file)
+ (string-append out "/bin/" file)))
+ '("caff" "caff" "caff" "gpgdir" "gpg-key2ps"
+ "gpglist" "gpg-mailkeys" "gpgparticipants")
+ '("caff" "pgp-clean" "pgp-fixkey" "gpgdir" "gpg-key2ps"
+ "gpglist" "gpg-mailkeys" "gpgparticipants"))
+ (for-each
+ (lambda (dir file)
+ (copy-file (string-append dir "/" file)
+ (string-append out "/share/man/man1/" file)))
+ '("caff" "caff" "caff" "gpgdir"
+ "gpg-key2ps" "gpglist" "gpg-mailkeys"
+ "gpgparticipants" "gpgsigs" "gpgwrap/doc"
+ "keyanalyze" "keyanalyze/pgpring" "keyanalyze")
+ '("caff.1" "pgp-clean.1" "pgp-fixkey.1" "gpgdir.1"
+ "gpg-key2ps.1" "gpglist.1" "gpg-mailkeys.1"
+ "gpgparticipants.1" "gpgsigs.1" "gpgwrap.1"
+ "process_keys.1" "pgpring.1" "keyanalyze.1")))
+ #t))
+ (add-after 'install 'wrap-programs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (wrap-program
+ (string-append out "/bin/caff")
+ `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB")))))
+ #t)))))
+ (synopsis "Collection of scripts for simplifying gnupg key signing")
+ (description
+ "Signing-party is a collection for all kinds of PGP/GnuPG related things,
including tools for signing keys, keyring analysis, and party preparation.
@enumerate
@item caff: CA - Fire and Forget signs and mails a key
@@ -751,10 +765,10 @@ including tools for signing keys, keyring analysis, and party preparation.
@item sig2dot: converts a list of GnuPG signatures to a .dot file
@item springgraph: creates a graph from a .dot file
@end enumerate")
- ;; gpl2+ for almost all programs, except for keyanalyze: gpl2
- ;; and caff and gpgsigs: bsd-3, see
- ;; http://packages.debian.org/changelogs/pool/main/s/signing-party/current/copyright
- (license license:gpl2))))
+ ;; gpl2+ for almost all programs, except for keyanalyze: gpl2
+ ;; and caff and gpgsigs: bsd-3, see
+ ;; http://packages.debian.org/changelogs/pool/main/s/signing-party/current/copyright
+ (license license:gpl2)))
(define-public pinentry-tty
(package