summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-14 04:02:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-14 04:02:14 +0200
commitb262aba7338b8e3aa97bccb91309848a553280e3 (patch)
tree5dee07822c2a2ff264ebbf6c14c7ba8c53565e4e /gnu/packages/gnupg.scm
parentff76a1e9cad607cb0b91f1e46c65aa1c87b131f6 (diff)
downloadguix-patches-b262aba7338b8e3aa97bccb91309848a553280e3.tar
guix-patches-b262aba7338b8e3aa97bccb91309848a553280e3.tar.gz
gnu: python-gnupg: Return #t from phase.
* gnu/packages/gnupg.scm (python-gnupg)[arguments]: Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index ff2efb759e..ecd280f6db 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -529,8 +529,8 @@ decrypt messages using the OpenPGP format by making use of GPGME.")
(setenv "USERNAME" "guixbuilder")
;; The doctests are extremely slow and sometimes time out,
;; so we disable them.
- (zero? (system* "python"
- "test_gnupg.py" "--no-doctests")))))))
+ (invoke "python"
+ "test_gnupg.py" "--no-doctests"))))))
(native-inputs
`(("gnupg" ,gnupg-1)))
(home-page "https://packages.python.org/python-gnupg/index.html")