summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-14 13:12:55 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-14 15:57:39 +0200
commitad7c6d290e58c3c9cb0ca573bf1ef44d124d11ec (patch)
treefbfcc085a119452d76ba19445463720b1e5f5948 /gnu/packages/gnupg.scm
parentdeb4f0a595e75a2d708ebe9ce26fb4d5fcfa0968 (diff)
downloadguix-patches-ad7c6d290e58c3c9cb0ca573bf1ef44d124d11ec.tar
guix-patches-ad7c6d290e58c3c9cb0ca573bf1ef44d124d11ec.tar.gz
libgpg-error: Fix cross-compilation error.
TODO: inform upstream about the cross-compilation error. * gnu/packages/gnupg.scm (libgpg-error)[arguments]{fix-gen-lock-obj.sh}: Prevent generated header files from being sprinkled with ā€˜\cā€™. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 1a7c682ad6..bb6fa4678b 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -100,6 +100,13 @@
(guix build utils))
#:phases
(modify-phases %standard-phases
+ ;; If this is left out, some generated header
+ ;; files will be sprinkled with ā€˜\cā€™, which
+ ;; the compiler won't like.
+ (add-after 'unpack 'fix-gen-lock-obj.sh
+ (lambda _
+ (substitute* "src/gen-lock-obj.sh"
+ (("if test -n `echo -n`") "if ! test -n `echo -n`"))))
;; When cross-compiling, some platform specific properties cannot
;; be detected. Create a symlink to the appropriate platform
;; file if required. Note that these platform files depend on