summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2018-05-21 17:03:53 +0200
committerAndreas Enge <andreas@enge.fr>2018-05-21 17:05:56 +0200
commita92d97266dffcd1ab5c40a379005a7db1fc3dad4 (patch)
tree0f685a88a12151f099d54febba6f4c3476f2ee49 /gnu/packages/gnupg.scm
parentfcb1dd99941cd7adf9651946397a1a8a52f61aa1 (diff)
downloadguix-patches-a92d97266dffcd1ab5c40a379005a7db1fc3dad4.tar
guix-patches-a92d97266dffcd1ab5c40a379005a7db1fc3dad4.tar.gz
gnu: pius: Fix incompatibility with newer GnuPG versions.
* gnu/packages/gnupg.scm (pius)[source]: Add patch. * gnu/packages/patches/pius.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 230afaec1b..a389186746 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2015, 2018 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
@@ -590,7 +590,8 @@ signing, decryption, verification, and key-listing parsing.")
version "/pius-" version ".tar.bz2"))
(sha256
(base32
- "1893hzpx3zv724drqv48csrn0cm98xw4ymb1zmhs2jvjj1778zfj"))))
+ "1893hzpx3zv724drqv48csrn0cm98xw4ymb1zmhs2jvjj1778zfj"))
+ (patches (search-patches "pius.patch"))))
(build-system python-build-system)
(inputs `(("perl" ,perl) ;for 'pius-party-worksheet'
("gpg" ,gnupg)