summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-11-21 19:41:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-11-21 19:41:43 +0200
commit9cf4ff199cd6114dacd199dcf62976978ef3dd5b (patch)
tree4ad2aeb5ac4cf9c6d9a2e04a446c8ddbca09c0e0 /gnu/packages/gnupg.scm
parentbf6859e45ad33aa631fc231b23df2d56aff97360 (diff)
parenta2aa746cfe38076b87d9cde2252904c0bddd9f9e (diff)
downloadguix-patches-9cf4ff199cd6114dacd199dcf62976978ef3dd5b.tar
guix-patches-9cf4ff199cd6114dacd199dcf62976978ef3dd5b.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index cec013074f..53fdc8200c 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -40,6 +40,8 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages crypto)
#:use-module (gnu packages emacs)
+ #:use-module (gnu packages enlightenment)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages guile)
#:use-module (gnu packages openldap)
#:use-module (gnu packages perl)
@@ -836,6 +838,34 @@ software.")))
"Pinentry provides a console and a Qt GUI that allows users to enter a
passphrase when @code{gpg} is run and needs it.")))
+(define-public pinentry-efl
+ (package
+ (inherit pinentry-tty)
+ (name "pinentry-efl")
+ (source
+ (origin
+ (inherit (package-source pinentry-tty))
+ (patches (search-patches "pinentry-efl.patch"))))
+ (arguments
+ '(#:configure-flags '("--enable-pinentry-efl")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (invoke "sh" "autogen.sh"))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal)
+ ,@(package-native-inputs pinentry-tty)))
+ (inputs
+ `(("efl" ,efl)
+ ,@(package-inputs pinentry-tty)))
+ (description
+ "Pinentry provides a console and a graphical interface for the
+@dfn{Enlightenment Foundation Libraries} (EFL) that allows users to enter a
+passphrase when @code{gpg} is run and needs it.")))
+
(define-public pinentry
(package (inherit pinentry-gtk2)
(name "pinentry")))