summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-04 18:46:33 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:21 -0500
commit55e5def90c4526df4d9bac85b2406331b2f9e691 (patch)
tree92ff0b413d24fe053d9435d48aba6b981277e2ce /gnu/packages/gnupg.scm
parent325184e3076b30f17c60e51ff94852246e88b324 (diff)
downloadguix-patches-55e5def90c4526df4d9bac85b2406331b2f9e691.tar
guix-patches-55e5def90c4526df4d9bac85b2406331b2f9e691.tar.gz
gnu: gnupg: Don't explicitly return #t from phases.
* gnu/packages/gnupg.scm (gnupg)[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 63b69eb8fd..501ef90742 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -317,14 +317,12 @@ compatible to GNU Pth.")
(substitute* "scd/scdaemon.c"
(("\"(libpcsclite\\.so[^\"]*)\"" _ name)
(string-append "\"" (assoc-ref inputs "pcsc-lite")
- "/lib/" name "\"")))
- #t))
+ "/lib/" name "\"")))))
(add-after 'build 'patch-scheme-tests
(lambda _
(substitute* (find-files "tests" ".\\.scm$")
(("/usr/bin/env gpgscm")
- (string-append (getcwd) "/tests/gpgscm/gpgscm")))
- #t))
+ (string-append (getcwd) "/tests/gpgscm/gpgscm")))))
(add-before 'build 'patch-test-paths
(lambda _
(substitute* '("tests/inittests"
@@ -336,8 +334,7 @@ compatible to GNU Pth.")
(substitute* "common/t-exectool.c"
(("/bin/cat") (which "cat"))
(("/bin/true") (which "true"))
- (("/bin/false") (which "false")))
- #t)))))
+ (("/bin/false") (which "false"))))))))
(home-page "https://gnupg.org/")
(synopsis "GNU Privacy Guard")
(description