summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-10-10 17:32:24 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-10 17:32:24 +0200
commit4d14902b9402a83db444d8d6818d0a4f438ce8c4 (patch)
tree85f05a0540ebcd4a1f192096c36271a287eb9fe8 /gnu/packages/gnupg.scm
parent647cfcf68184e8558fcea751ef6d95b6e5d86ae1 (diff)
parent6c50e1dc0625f89884cff40b22627091efa37708 (diff)
downloadguix-patches-4d14902b9402a83db444d8d6818d0a4f438ce8c4.tar
guix-patches-4d14902b9402a83db444d8d6818d0a4f438ce8c4.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 4acc434093..e0c11cb0a1 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015, 2018 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
@@ -503,6 +503,14 @@ interface (FFI) of Guile.")
`(("guile" ,guile-2.0)
,@(alist-delete "guile" (package-inputs guile-gcrypt))))))
+(define-public guile3.0-gcrypt
+ (package
+ (inherit guile-gcrypt)
+ (name "guile3.0-gcrypt")
+ (inputs
+ `(("guile" ,guile-next)
+ ,@(alist-delete "guile" (package-inputs guile-gcrypt))))))
+
(define-public python-gpg
(package
(name "python-gpg")