summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-18 17:10:58 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-18 17:35:47 +0100
commit478362c949eda7b397c971bd2a7eb502694dfc34 (patch)
tree4a4f331de94efa53bed6849c79e0772de96f9482 /gnu/packages/gnupg.scm
parent38085f0fbf456bfd72441da768c04629bd026c22 (diff)
downloadguix-patches-478362c949eda7b397c971bd2a7eb502694dfc34.tar
guix-patches-478362c949eda7b397c971bd2a7eb502694dfc34.tar.gz
gnu: pgpdump: Remove bogus DESTDIR usage.
* gnu/packages/gnupg.scm (pgpdump)[arguments]: Gexp. Remove custom #:configure-flags, and DESTDIR from #:make-flags.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 85042dbeaf..7706688b93 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -75,6 +75,7 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages popt)
#:use-module (gnu packages xdisorg)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix utils)
@@ -1039,10 +1040,9 @@ them to transform your existing public key into a secret key.")
(base32 "080ayqqxb13ngpg6zvaipszwnjadafw3ni7w7gg189cmh3lab7cq"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no make check
- #:configure-flags (list "--prefix=/")
- #:make-flags (list ,(string-append "CC=" (cc-for-target))
- (string-append "DESTDIR=" (assoc-ref %outputs "out")))))
+ (list #:tests? #f ; no make check
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target)))))
(inputs
(list zlib))
(home-page "https://www.mew.org/~kazu/proj/pgpdump/en/")