summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-07 12:11:45 -0500
committerLeo Famulari <leo@famulari.name>2017-01-07 19:00:58 -0500
commit1c9cea74b48348a24bbd38e51345c548255666e4 (patch)
tree1e4484e9a12dd142dde0fde345ab2d9d6b356f21 /gnu/packages/gnupg.scm
parent261f56914cd9cd19ecb38c59f1bb2b42f3514e72 (diff)
downloadguix-patches-1c9cea74b48348a24bbd38e51345c548255666e4.tar
guix-patches-1c9cea74b48348a24bbd38e51345c548255666e4.tar.gz
gnu: python-pygpgme: Fix build failure.
* gnu/packages/patches/python-pygpgme-fix-pinentry-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gnupg.scm (python-pygpgme, python2-pygpgme)[source]: Use it.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 5f6215b854..dc801a6a4f 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -434,7 +434,8 @@ distributed separately.")
;; Unfortunately, we have to disable some tests due to some gpg-agent
;; goofiness... see:
;; https://bugs.launchpad.net/pygpgme/+bug/999949
- (patches (search-patches "pygpgme-disable-problematic-tests.patch"))))
+ (patches (search-patches "pygpgme-disable-problematic-tests.patch"
+ "python-pygpgme-fix-pinentry-tests.patch"))))
(arguments
`(#:phases
(modify-phases %standard-phases