summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-11-16 09:34:27 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-16 09:34:27 +0100
commit154d97abdd16674fdebc763351f661bbcdc869a4 (patch)
tree0277a9380edd1390f16e432283d32499ffed36d1 /gnu/packages/gnupg.scm
parente4696c69d75f4fcf54c42beeb928032726bdaf7d (diff)
parent87e7faa2ae641d8302efc8b90f1e45f43f67f6da (diff)
downloadguix-patches-154d97abdd16674fdebc763351f661bbcdc869a4.tar
guix-patches-154d97abdd16674fdebc763351f661bbcdc869a4.tar.gz
Merge remote-tracking branch master into core-updates
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm36
1 files changed, 21 insertions, 15 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index b31781a7b6..7f01f8a0a6 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -66,6 +66,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages tor)
#:use-module (gnu packages web)
+ #:use-module (gnu packages xorg)
#:use-module (gnu packages xml)
#:use-module (guix packages)
#:use-module (guix download)
@@ -907,8 +908,6 @@ software.")))
(inputs
`(("qtbase" ,qtbase)
,@(package-inputs pinentry-tty)))
- (arguments
- `(#:configure-flags '("CXXFLAGS=-std=gnu++11")))
(description
"Pinentry provides a console and a Qt GUI that allows users to enter a
passphrase when @code{gpg} is run and needs it.")))
@@ -1038,7 +1037,7 @@ files, to verify signatures, and to manage the private and public keys.")
(define-public parcimonie
(package
(name "parcimonie")
- (version "0.10.3")
+ (version "0.11.0")
(source (origin
(method url-fetch)
(uri (string-append "https://gaffer.boum.org/intrigeri/files/"
@@ -1046,10 +1045,10 @@ files, to verify signatures, and to manage the private and public keys.")
version ".tar.gz"))
(sha256
(base32
- "1kf891117s1f3k6lxvbjdb21va9gxh29vlp9bd664ssgw266rcyb"))))
+ "14pvapvzrxh1yh8zgcj1llmc2dd8g1fgzskxlja21gmw8c88aqdk"))))
(build-system perl-build-system)
(inputs
- `(("gnupg" ,gnupg-1) ; This is the version used by perl-gnupg-interface
+ `(("gnupg" ,gnupg)
("perl-config-general" ,perl-config-general)
("perl-clone" ,perl-clone)
("perl-data" ,perl-data)
@@ -1069,10 +1068,12 @@ files, to verify signatures, and to manage the private and public keys.")
("perl-moox-handlesvia" ,perl-moox-handlesvia)
("perl-moox-late" ,perl-moox-late)
("perl-moox-options" ,perl-moox-options)
+ ("perl-moox-strictconstructor" ,perl-moox-strictconstructor)
("perl-namespace-clean" ,perl-namespace-clean)
("perl-net-dbus" ,perl-net-dbus)
("perl-net-dbus-glib" ,perl-net-dbus-glib)
("perl-path-tiny" ,perl-path-tiny)
+ ("perl-strictures" ,perl-strictures-2)
("perl-test-most" ,perl-test-most)
("perl-test-trap" ,perl-test-trap)
("perl-time-duration" ,perl-time-duration)
@@ -1084,24 +1085,29 @@ files, to verify signatures, and to manage the private and public keys.")
("perl-xml-parser" ,perl-xml-parser)
("perl-xml-twig" ,perl-xml-twig)
("torsocks" ,torsocks)))
+ (native-inputs
+ `(("xorg-server" ,xorg-server)))
(arguments
`(#:phases
(modify-phases %standard-phases
;; Needed for using gpg-connect-agent during tests.
- (add-before 'check 'set-HOME
- (lambda _ (setenv "HOME" "/tmp") #t))
+ (add-before 'check 'prepare-for-tests
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((xorg-server (assoc-ref inputs "xorg-server")))
+ (system (string-append xorg-server "/bin/Xvfb :1 &"))
+ (setenv "DISPLAY" ":1")
+ (setenv "HOME" "/tmp")
+ ;; These tests are known to fail
+ (delete-file "t/32-keyserver_defined_on_command_line.t")
+ (delete-file "t/33-checkGpgHasDefinedKeyserver.t")
+ ;; The applet is deprecated upstream.
+ (delete-file "t/00-load_all.t")
+ #t)))
(add-before 'install 'fix-references
(lambda* (#:key inputs outputs #:allow-other-keys)
(substitute* "lib/App/Parcimonie/GnuPG/Interface.pm"
- (("gpg2") "gpg")
;; Skip check whether dependencies are in the PATH
- (("defined which.*") "")
- (("call\\('parcimonie-torified-gpg'\\)")
- (string-append "call('" (assoc-ref outputs "out")
- "/bin/parcimonie-torified-gpg')")))
- (substitute* "bin/parcimonie-torified-gpg"
- (("torsocks") (string-append (assoc-ref inputs "torsocks")
- "/bin/torsocks")))
+ (("defined which.*") ""))
#t))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)