summaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-07-27 04:07:50 +0200
committerLudovic Courtès <ludo@gnu.org>2020-07-29 00:22:01 +0200
commite402ccd00308d2db6ff86d4bd180c25c8dd0ce87 (patch)
tree015d98667baff0d989fdf59f1f7616ed4ad5866a /gnu/packages/gnunet.scm
parent12a3d7d6f747b2b3c456ba20727e1ac97f9a952f (diff)
downloadguix-patches-e402ccd00308d2db6ff86d4bd180c25c8dd0ce87.tar
guix-patches-e402ccd00308d2db6ff86d4bd180c25c8dd0ce87.tar.gz
gnu: libextractor: Update to 1.10.
* gnu/packages/gnunet.scm (libextractor): Update to 1.10. [arguments]: Add 'fix-exiv2-tests' phase. [inputs]: Add GIFLIB, remove TIDY-HTML. * gnu/packages/patches/libextractor-exiv2.patch: Remove. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm23
1 files changed, 14 insertions, 9 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 979dadbe2e..467e51db5f 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -73,24 +74,22 @@
(define-public libextractor
(package
(name "libextractor")
- (version "1.9")
+ (version "1.10")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/libextractor/libextractor-"
version ".tar.gz"))
(sha256
(base32
- "1zz2zvikvfibxnk1va3kgzs7djsmiqy7bmk8y01vbsf54ryjb3zh"))
- (patches (search-patches "libextractor-exiv2.patch"))))
+ "0mr38g7kfn3p050hd3hckbcz2yd3za6dwl1c26x2kjf7vnsi3vcy"))))
(build-system gnu-build-system)
;; WARNING: Checks require /dev/shm to be in the build chroot, especially
;; not to be a symbolic link to /run/shm.
;; FIXME:
;; The following dependencies are all optional, but should be
;; available for maximum coverage:
- ;; * libmagic (file)
;; * librpm (rpm) ; investigate failure
- ;; * libgif (giflib) ; investigate failure
+ ;; * libtidy-html (tidy-html) ; investigate failure
(inputs
`(("exiv2" ,exiv2)
("bzip2" ,bzip2)
@@ -98,6 +97,7 @@
("ffmpeg" ,ffmpeg)
("file" ,file) ;libmagic, for the MIME plug-in
("glib" ,glib)
+ ("giflib" ,giflib)
("gstreamer" ,gstreamer)
("gst-plugins-base" ,gst-plugins-base)
("gtk+" ,gtk+)
@@ -108,7 +108,6 @@
("libmpeg2" ,libmpeg2)
("libmp4v2" ,libmp4v2)
("libsmf" ,libsmf)
- ("tidy-html" ,tidy-html)
("libogg" ,libogg)
("libtiff" ,libtiff)
("libvorbis" ,libvorbis)
@@ -120,12 +119,18 @@
(arguments
`(#:configure-flags
(list (string-append "--with-ltdl="
- (assoc-ref %build-inputs "libltdl"))
- (string-append "--with-tidy="
- (assoc-ref %build-inputs "tidy-html")))
+ (assoc-ref %build-inputs "libltdl")))
#:parallel-tests? #f
#:phases
(modify-phases %standard-phases
+ (add-after 'configure 'fix-exiv2-tests
+ ;; exiv2>=0.27.3 rounds geolocation
+ ;; https://github.com/Exiv2/exiv2/pull/1107/commits/db1be4ae8e1077949fcb6a960e93069d6a41b395#diff-f3f55183ccbe956c720c86e61f708d9f
+ (lambda _
+ (substitute* "src/plugins/test_exiv2.c"
+ (("17.585\\\\\" ") "18\\\"")
+ (("21.713\\\\\" ") "22\\\""))
+ #t))
(add-after 'install 'move-static-libraries
(lambda* (#:key outputs #:allow-other-keys)
;; Move static libraries to the "static" output.