summaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-07 21:58:39 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-07 22:00:53 +0200
commitc4bfce994e0622a921af2ebd996be14ceb492c11 (patch)
tree82998ce229f768354e85b8468e0ffd90b63adb0d /gnu/packages/gnunet.scm
parent0ef54303f35e559d18c679abd4b7a0a5aebff774 (diff)
downloadguix-patches-c4bfce994e0622a921af2ebd996be14ceb492c11.tar
guix-patches-c4bfce994e0622a921af2ebd996be14ceb492c11.tar.gz
gnu: libmicrohttpd: Update to 0.9.63.
* gnu/packages/gnunet.scm (libmicrohttpd): Update to 0.9.63. [arguments]: Remove custom phase to add missing LDFLAGS.
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 685cbdedec..f02bad8166 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -148,14 +148,14 @@ tool to extract metadata from a file and print the results.")
(define-public libmicrohttpd
(package
(name "libmicrohttpd")
- (version "0.9.62")
+ (version "0.9.63")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/libmicrohttpd/libmicrohttpd-"
version ".tar.gz"))
(sha256
(base32
- "0jfvi1fb4im3a3m8qishbmzx3zch993c0mhvl2k92l1zf1yhjgmx"))))
+ "173lj66crwvhzwp1r812sc5h1hda7g6lb9l1y5zf7w3pw4dnzhrp"))))
(build-system gnu-build-system)
(inputs
`(("curl" ,curl)
@@ -164,17 +164,7 @@ tool to extract metadata from a file and print the results.")
("openssl" ,openssl)
("zlib" ,zlib)))
(arguments
- `(#:parallel-tests? #f
- #:phases (modify-phases %standard-phases
- (add-before 'check 'add-missing-LDFLAGS
- (lambda _
- ;; The two test_upgrade* programs depend on GnuTLS
- ;; directly but lack -lgnutls; add it.
- (substitute* "src/microhttpd/Makefile"
- (("^test_upgrade(.*)LDFLAGS = (.*)$" _ first rest)
- (string-append "test_upgrade" first
- "LDFLAGS = -lgnutls " rest)))
- #t)))))
+ `(#:parallel-tests? #f))
(synopsis "C library implementing an HTTP 1.1 server")
(description
"GNU libmicrohttpd is a small, embeddable HTTP server implemented as a