summaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-03-14 10:43:47 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-18 15:05:08 +0100
commita3f2c295e7f8719dc47d5757b89188e0ed68faf2 (patch)
treecc56265e65362b54605e611d24dea091b59c5db3 /gnu/packages/gnunet.scm
parent47956fa0c24efcdcba3493f0231c30e9a39ec7df (diff)
downloadguix-patches-a3f2c295e7f8719dc47d5757b89188e0ed68faf2.tar
guix-patches-a3f2c295e7f8719dc47d5757b89188e0ed68faf2.tar.gz
gnu: libextractor: Update to 1.9.
* gnu/packages/gnunet (libextractor): Update to 1.9. [source]: Remove patches. * gnu/packages/patches/libextractor-CVE-2018-20430.patch gnu/packages/patches/libextractor-CVE-2018-20431.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 93c905406f..19e99644dd 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2015, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017, 2018 ng0 <ng0@n0.is>
+;;; Copyright © 2016, 2017, 2018, 2019 ng0 <ng0@n0.is>
;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;;
@@ -68,16 +68,14 @@
(define-public libextractor
(package
(name "libextractor")
- (version "1.8")
+ (version "1.9")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/libextractor/libextractor-"
version ".tar.gz"))
- (patches (search-patches "libextractor-CVE-2018-20430.patch"
- "libextractor-CVE-2018-20431.patch"))
(sha256
(base32
- "1z1cb35griqzvshqdv5ck98dy0sgpsswn7fgiy7lbzi34sma8dg2"))))
+ "1zz2zvikvfibxnk1va3kgzs7djsmiqy7bmk8y01vbsf54ryjb3zh"))))
(build-system gnu-build-system)
;; WARNING: Checks require /dev/shm to be in the build chroot, especially
;; not to be a symbolic link to /run/shm.