summaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-11 09:08:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-11 09:08:10 +0300
commit90d8ef6bcb2b1216458ba7a99bb33947538e4461 (patch)
tree395d379cd0a67e802e69280912e44d20c7ec7e50 /gnu/packages/gnunet.scm
parentb9fe72bf4d0e4911d7da5c0c126b41b58c4b37f0 (diff)
downloadguix-patches-90d8ef6bcb2b1216458ba7a99bb33947538e4461.tar
guix-patches-90d8ef6bcb2b1216458ba7a99bb33947538e4461.tar.gz
gnu: gnunet: Use 'modify-phases'.
* gnu/packages/gnunet.scm (gnunet)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm22
1 files changed, 10 insertions, 12 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 0083bf1fa6..d9387b96d6 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -247,19 +247,17 @@ supports HTTP, HTTPS and GnuTLS.")
;; test_gnunet_service_arm fails; reported upstream
#:tests? #f
#:phases
+ (modify-phases %standard-phases
;; swap check and install phases and set paths to installed binaries
- (alist-cons-before
- 'check 'set-path-for-check
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (setenv "GNUNET_PREFIX" (string-append out "/lib"))
- (setenv "PATH" (string-append (getenv "PATH") ":" out "/bin"))))
- (alist-cons-after
- 'install 'check
- (assoc-ref %standard-phases 'check)
- (alist-delete
- 'check
- %standard-phases)))))
+ (add-before 'check 'set-path-for-check
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "GNUNET_PREFIX" (string-append out "/lib"))
+ (setenv "PATH" (string-append (getenv "PATH") ":" out "/bin")))
+ #t))
+ (add-after 'install 'check
+ (assoc-ref %standard-phases 'check))
+ (delete 'check))))
(synopsis "Secure, decentralized, peer-to-peer networking framework")
(description
"GNUnet is a framework for secure peer-to-peer networking. The