summaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2018-01-18 23:07:27 +0000
committerLudovic Courtès <ludo@gnu.org>2018-01-23 10:15:10 +0100
commit8bf127d5ab5f95dc606fbec2b8de5c942dd79b9d (patch)
treea965c2d10161faf913c7898a0d8d955e8eba382b /gnu/packages/gnunet.scm
parentcba386c1295b7054df22dfb4662b1b92f668e2c0 (diff)
downloadguix-patches-8bf127d5ab5f95dc606fbec2b8de5c942dd79b9d.tar
guix-patches-8bf127d5ab5f95dc606fbec2b8de5c942dd79b9d.tar.gz
gnu: gnurl: Add '--with-ca-bundle' path to configure-flags.
As a fork of cURL, gnURL on Guix needs to be made aware of the certificate store to prevent the well-known issue we have. * gnu/packages/gnunet.scm (gnurl)[configure-flags]: Add '--with-ca-bundle=/etc/ssl/certs/ca-certificates.crt'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 2d238febce..0ebfc9116a 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2015, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017 ng0 <ng0@n0.is>
+;;; Copyright © 2016, 2017, 2018 ng0 <ng0@n0.is>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -205,7 +205,8 @@ authentication and support for SSL3 and TLS.")
("pkg-config" ,pkg-config)
("python" ,python-2)))
(arguments
- `(#:configure-flags (list "--disable-ntlm-wb")
+ `(#:configure-flags (list "--disable-ntlm-wb"
+ "--with-ca-bundle=/etc/ssl/certs/ca-certificates.crt")
#:test-target "test"
#:parallel-tests? #f
#:phases