summaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorSree Harsha Totakura <sreeharsha@totakura.in>2014-02-18 21:57:43 +0100
committerAndreas Enge <andreas@enge.fr>2014-02-18 22:54:31 +0100
commit67543125f3f838c8789877797aa92fda68bdcd9e (patch)
treea9de88baf1d23c066f7e5ad4d02b392a91590dc3 /gnu/packages/gnunet.scm
parent7c869effd4a75b86a00f699feba95a709a896622 (diff)
downloadguix-patches-67543125f3f838c8789877797aa92fda68bdcd9e.tar
guix-patches-67543125f3f838c8789877797aa92fda68bdcd9e.tar.gz
gnu: gnurl: Do not disable testcase 1022.
* gnu/packages/gnunet.scm (gnurl): Do not disable testcase 1022. Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index b08479624d..7f7a6fd6f9 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -167,20 +167,13 @@ and support for SSL3 and TLS.")
"--disable-file" "--disable-ftp")
#:test-target "test"
#:parallel-tests? #f
- ;; We have to patch runtests.pl in tests/ directory and add a failing
- ;; test due to curl->gnurl name change to tests/data/DISABLED
+ ;; We have to patch runtests.pl in tests/ directory
#:phases
(alist-cons-before
'check 'patch-runtests
(lambda _
- (with-directory-excursion "tests"
- (substitute* "runtests.pl"
- (("/bin/sh")
- (which "sh")))
- (let* ((port (open-file "data/DISABLED" "a")))
- (newline port)
- (display "1022" port)
- (close port))))
+ (substitute* "tests/runtests.pl"
+ (("/bin/sh") (which "sh"))))
%standard-phases)))
(synopsis "Microfork of cURL with support for the HTTP/HTTPS/GnuTLS subset of cURL")
(description