summaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2018-12-31 07:00:39 +0800
committerAlex Vong <alexvong1995@gmail.com>2019-01-04 07:34:25 +0800
commit5651e74cc6c1d1b8a2ef1d40e6f14e1123a7de97 (patch)
treea35acde127341e8629c26470f143182088c8a2ed /gnu/packages/gnunet.scm
parent47719c9bc07940618ce582e747873217253bb870 (diff)
downloadguix-patches-5651e74cc6c1d1b8a2ef1d40e6f14e1123a7de97.tar
guix-patches-5651e74cc6c1d1b8a2ef1d40e6f14e1123a7de97.tar.gz
gnu: guile-gnunet: Update to 0.0-1.d12167a.
* gnu/packages/gnunet.scm (guile-gnunet): Update to 0.0-1.d12167a. [version]: Use git-version. [source]: Use git-file-name.
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 79584fcf03..62bb3026dd 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -310,19 +310,20 @@ kinds of basic applications for the foundation of a GNU internet.")
(home-page "https://gnunet.org/")))
(define-public guile-gnunet ;GSoC 2015!
- (let ((commit "383eac2aab175d8d9ea5315c2f1c8a5055c76a52"))
+ (let ((commit "d12167ab3c8d7d6caffd9c606e389ef043760602")
+ (revision "1"))
(package
(name "guile-gnunet")
- (version (string-append "0.0." (string-take commit 7)))
+ (version (git-version "0.0" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://git.savannah.gnu.org/git/guix/gnunet.git/")
(commit commit)))
- (file-name (string-append name "-" version "-checkout"))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0k6mn28isjlxrnvbnblab3nh2xqx1b7san8k98kc35ap9lq0iz8w"))))
+ "0nqc18jh9j30y4l6yh6j35byfg6qalq7yr3frv9rk10qa041c2sv"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
("autoconf" ,autoconf-wrapper)