summaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2016-12-23 11:29:32 +0000
committerLeo Famulari <leo@famulari.name>2016-12-23 11:58:03 -0500
commit4ec08b637b2dd636e0110b4d7dd88a4d14bdcc55 (patch)
tree938f9bba4144c6b0654c95eb643e5a32b684ec44 /gnu/packages/gnunet.scm
parenta0e43c9fa74eb349ae3ece9ec9cc01a5a2943f10 (diff)
downloadguix-patches-4ec08b637b2dd636e0110b4d7dd88a4d14bdcc55.tar
guix-patches-4ec08b637b2dd636e0110b4d7dd88a4d14bdcc55.tar.gz
gnu: gnurl: Make tests more verbose.
* gnu/packages/gnunet.scm (gnurl)[arguments]: Replace the 'check' phase. Move the 'disable-test1026' and 'patch-runtests' phases into 'check' phase. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index fb72540dc8..495a7de883 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -205,16 +205,17 @@ and support for SSL3 and TLS.")
;; Clear artifacts left (shebangs) from release preparation.
(lambda _
(zero? (system* "./buildconf"))))
- (add-before 'check 'disable-test1026
+ (replace 'check
(lambda _
;; It is unclear why test1026 fails, however the content of it
;; suggests that it is not vital for gnurl.
(delete-file "tests/data/test1026")
- #t))
- (add-before 'check 'patch-runtests
- (lambda _
+
(substitute* "tests/runtests.pl"
(("/bin/sh") (which "sh")))
+
+ ;; Make test output more verbose.
+ (zero? (system* "make" "-C" "tests" "test"))
#t)))))
(synopsis "Microfork of cURL with support for the HTTP/HTTPS/GnuTLS subset of cURL")
(description