summaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-08-21 09:45:54 +0000
committerChristopher Baines <mail@cbaines.net>2017-10-01 10:50:37 +0100
commit1472f630028a341b05d9551976b4e22b123bb94b (patch)
tree8f3a5d611fd527889395eb6d53a3138c27b64e4c /gnu/packages/gnunet.scm
parentfd67e3a22f9ce7298bfecb94bcf804378ed9220d (diff)
downloadguix-patches-1472f630028a341b05d9551976b4e22b123bb94b.tar
guix-patches-1472f630028a341b05d9551976b4e22b123bb94b.tar.gz
gnu: libmicrohttpd: Use 'gnutls/dane' as input.
This switches the used GnuTLS to the one recommended by the GNUnet Documentation (Chapter "Installation Handbook", Section "Generic installation instructions") where a specific order of dependency installation is required. In this order libunbound is installed first, then GnuTLS, then libgnurl, followed by libmicrohttpd. * gnu/packages/gnunet.scm (libmicrohttpd)[inputs]: Replace gnutls with 'gnutls/dane'. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index bb434c9ece..98574994aa 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -155,7 +155,7 @@ tool to extract metadata from a file and print the results.")
(build-system gnu-build-system)
(inputs
`(("curl" ,curl)
- ("gnutls" ,gnutls)
+ ("gnutls" ,gnutls/dane)
("libgcrypt" ,libgcrypt)
("openssl" ,openssl)
("zlib" ,zlib)))