summaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2018-01-23 12:14:55 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-01-23 12:16:29 +0100
commit0741c3a46adf54009ef25463eb7739e353710604 (patch)
treee54193cc6536219a44789c7c98278dd17d88c56e /gnu/packages/gnunet.scm
parent0db22b32ce5efa34c8f4f12649a248bce2fff250 (diff)
downloadguix-patches-0741c3a46adf54009ef25463eb7739e353710604.tar
guix-patches-0741c3a46adf54009ef25463eb7739e353710604.tar.gz
gnu: gnunet: Use invoke.
* gnu/packages/gnunet.scm (gnurl)[arguments]: Substitute invoke for system*. (guile-gnunet)[arguments]: Likewise. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 0ebfc9116a..5e47f2ebfc 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -227,8 +227,7 @@ authentication and support for SSL3 and TLS.")
(("/bin/sh") (which "sh")))
;; Make test output more verbose.
- (zero? (system* "make" "-C" "tests" "test"))
- #t)))))
+ (invoke "make" "-C" "tests" "test"))))))
(synopsis "Microfork of cURL with support for the HTTP/HTTPS/GnuTLS subset of cURL")
(description
"Gnurl is a microfork of cURL, a command line tool for transferring data
@@ -326,7 +325,7 @@ kinds of basic applications for the foundation of a GNU internet.")
'(#:phases (modify-phases %standard-phases
(add-after 'unpack 'bootstrap
(lambda _
- (zero? (system* "autoreconf" "-vfi")))))))
+ (invoke "autoreconf" "-vfi"))))))
(native-inputs `(("pkg-config" ,pkg-config)
("autoconf" ,(autoconf-wrapper))
("automake" ,automake)))