summaryrefslogtreecommitdiff
path: root/gnu/packages/gnucash.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-06-06 15:17:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-06-11 16:07:08 +0200
commit5c881f3211ba8c702e7c9d6bdd2f2da2a8e3064c (patch)
tree3c94a65e6b10db141d8e73ee55e7a49425e36005 /gnu/packages/gnucash.scm
parente4aab734875a40f991b6ecba1247be6fc248f15f (diff)
downloadguix-patches-5c881f3211ba8c702e7c9d6bdd2f2da2a8e3064c.tar
guix-patches-5c881f3211ba8c702e7c9d6bdd2f2da2a8e3064c.tar.gz
gnu: Add gwenhywfar.
* gnu/packages/gnucash.scm (gwenhywfar): New variable.
Diffstat (limited to 'gnu/packages/gnucash.scm')
-rw-r--r--gnu/packages/gnucash.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index c39324c691..25801aa66e 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -25,12 +25,14 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gnupg)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
#:use-module (gnu packages xml))
@@ -107,3 +109,44 @@ the double-entry accounting practice. It includes support for QIF/OFX/HBCI
import and transaction matching. It also automates several tasks, such as
financial calculations or scheduled transactions.")
(license license:gpl3+)))
+
+(define-public gwenhywfar
+ (package
+ (name "gwenhywfar")
+ (version "4.15.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.aquamaniac.de/sites/download/download.php?"
+ "package=01&release=201&file=01&dummy=gwenhywfar-"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0fp67s932x66xfljb26zbrn8ambbc5y5c3hllr6l284nr63qf3ka"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--disable-network-checks"
+ ;; Both GTK+2 and QT4 are supported.
+ "--with-guis=gtk2"
+ (string-append "--with-openssl-includes="
+ (assoc-ref %build-inputs "openssl") "/include")
+ (string-append "--with-openssl-libs="
+ (assoc-ref %build-inputs "openssl") "/lib"))))
+ (inputs
+ `(("libgcrypt" ,libgcrypt)
+ ("gnutls" ,gnutls)
+ ("openssl" ,openssl)
+ ("gtk+" ,gtk+-2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://www.aquamaniac.de/sites/aqbanking/index.php")
+ (synopsis "Utility library for networking and security applications")
+ (description
+ "This package provides a helper library for networking and security
+applications and libraries. It is used by AqBanking.")
+ ;; The license includes an explicit additional permission to compile and
+ ;; distribute this library with the OpenSSL Toolkit.
+ (license license:lgpl2.1+)))
+