summaryrefslogtreecommitdiff
path: root/gnu/packages/gnu-pw-mgr.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-20 22:34:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-20 22:34:53 +0300
commitff7bba573ac6b51836718cfdc81b638caf11488b (patch)
tree15255c2e8a7105ef1e2db26760971a61157759ba /gnu/packages/gnu-pw-mgr.scm
parent5d351adaca9327f126f4996f29ebc041edb47c31 (diff)
downloadguix-patches-ff7bba573ac6b51836718cfdc81b638caf11488b.tar
guix-patches-ff7bba573ac6b51836718cfdc81b638caf11488b.tar.gz
gnu: gnu-pw-mgr: Update to 2.7.
* gnu/packages/gnu-pw-mgr.scm (gnu-pw-mgr): Update to 2.7. [arguments]: Add new phase to work around /dev/tty not being available in the build environment.
Diffstat (limited to 'gnu/packages/gnu-pw-mgr.scm')
-rw-r--r--gnu/packages/gnu-pw-mgr.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/gnu-pw-mgr.scm b/gnu/packages/gnu-pw-mgr.scm
index 6eb8224cef..321a7f87d7 100644
--- a/gnu/packages/gnu-pw-mgr.scm
+++ b/gnu/packages/gnu-pw-mgr.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,7 +30,7 @@
(define-public gnu-pw-mgr
(package
(name "gnu-pw-mgr")
- (version "2.4.2")
+ (version "2.7")
(source
(origin
(method url-fetch)
@@ -38,7 +38,7 @@
version ".tar.xz"))
(sha256
(base32
- "1yvdzc5w37qrjrkby5699ygj9bhkvgi3zk9k9jcjry1j6b7wdl17"))))
+ "1ra8in91qx6n8jydb8kwl2rnqaa2hix5pyawn6nvyqs815h9gx17"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -47,6 +47,12 @@
(lambda _
(substitute* "tests/dom.test"
(("/usr/bin/printf") (which "printf")))
+ #t))
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; In build environment, There is no /dev/tty
+ (substitute* "tests/base.test"
+ (("/dev/tty") "/dev/null"))
#t)))))
(native-inputs
`(("which" ,which)))