summaryrefslogtreecommitdiff
path: root/gnu/packages/gnu-pw-mgr.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-06-18 20:02:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-06-18 20:02:39 +0300
commita181e858c7ece2bee3ec9fe49956b74ce508a25b (patch)
tree5aac6ddcb50a16217c6e362d7a78b466c28b46c9 /gnu/packages/gnu-pw-mgr.scm
parentbfc810ca131ea9d0ec93a59ee665573b2304f2d1 (diff)
downloadguix-patches-a181e858c7ece2bee3ec9fe49956b74ce508a25b.tar
guix-patches-a181e858c7ece2bee3ec9fe49956b74ce508a25b.tar.gz
gnu: gnu-pw-mgr: Update to 2.3.1.
* gnu/packages/gnu-pw-mgr.scm (gnu-pw-mgr): Update to 2.3.1. [arguments]: Add phase to patch more shebangs.
Diffstat (limited to 'gnu/packages/gnu-pw-mgr.scm')
-rw-r--r--gnu/packages/gnu-pw-mgr.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/gnu-pw-mgr.scm b/gnu/packages/gnu-pw-mgr.scm
index 906e7d3cf8..6bb5fea84b 100644
--- a/gnu/packages/gnu-pw-mgr.scm
+++ b/gnu/packages/gnu-pw-mgr.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,7 +30,7 @@
(define-public gnu-pw-mgr
(package
(name "gnu-pw-mgr")
- (version "2.0")
+ (version "2.3.1")
(source
(origin
(method url-fetch)
@@ -38,8 +38,16 @@
version ".tar.xz"))
(sha256
(base32
- "19qvg37snfa8s06q5crx25m1r1n4l0wvfpkbdxz17q7whp0plrl6"))))
+ "05vv6n5sqdswhzm21cqn8m2p6avblxl3cv7b39nqx8yxf58gi2xv"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'patch-source-shebangs 'patch-more-shebangs
+ (lambda _
+ (substitute* "tests/dom.test"
+ (("/usr/bin/printf") (which "printf")))
+ #t)))))
(native-inputs
`(("which" ,which)
("autogen" ,autogen)))