summaryrefslogtreecommitdiff
path: root/gnu/packages/gnu-doc.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2016-03-23 22:18:46 +0100
committerLudovic Courtès <ludo@gnu.org>2016-04-01 00:05:42 +0200
commitec0730cb6705d674cc6c52819c81ffb32f693ab8 (patch)
treebf46e972bac2863adc909c82e2de3c5dbcc74252 /gnu/packages/gnu-doc.scm
parentf4033fb5da9f07dce2b8049b1d7214c492790581 (diff)
downloadguix-patches-ec0730cb6705d674cc6c52819c81ffb32f693ab8.tar
guix-patches-ec0730cb6705d674cc6c52819c81ffb32f693ab8.tar.gz
gnu: Add gnu-standards.
* gnu/packages/gnu-doc.scm: New file. * gnu-system.am: Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnu-doc.scm')
-rw-r--r--gnu/packages/gnu-doc.scm74
1 files changed, 74 insertions, 0 deletions
diff --git a/gnu/packages/gnu-doc.scm b/gnu/packages/gnu-doc.scm
new file mode 100644
index 0000000000..572647d024
--- /dev/null
+++ b/gnu/packages/gnu-doc.scm
@@ -0,0 +1,74 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages gnu-doc)
+ #:use-module (gnu packages base)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages texinfo)
+
+ #:use-module (guix build-system trivial)
+ #:use-module (guix cvs-download)
+ #:use-module (guix licenses)
+ #:use-module (guix packages))
+
+(define-public gnu-standards
+ (package
+ (name "gnu-standards")
+ (version "2016-03-25")
+ (source
+ (origin
+ (method cvs-fetch)
+ (uri (cvs-reference
+ (root-directory
+ ":pserver:anonymous@cvs.savannah.gnu.org:/sources/gnustandards")
+ (module "gnustandards")
+ (revision "2016-03-25")))
+ (sha256
+ (base32
+ "0qn7mzdjqwc6h9prin22x6kj9iqipxpbzldzhmis7q4x4hpi61vj"))))
+ (build-system trivial-build-system)
+ (native-inputs `(("gzip" ,gzip)
+ ("source" ,source)
+ ("texinfo" ,texinfo)))
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((gzip (assoc-ref %build-inputs "gzip"))
+ (source (assoc-ref %build-inputs "source"))
+ (texinfo (assoc-ref %build-inputs "texinfo"))
+ (info-dir (string-append %output "/share/info")))
+ (setenv "PATH" (string-append gzip "/bin"
+ ":" texinfo "/bin"))
+ (mkdir-p info-dir)
+ (system* "makeinfo" "--output" info-dir
+ (string-append source "/maintain.texi"))
+ (system* "makeinfo" "--output" info-dir
+ (string-append source "/standards.texi"))
+ (system* "gzip" (string-append info-dir "/maintain.info"))
+ (system* "gzip" (string-append info-dir "/standards.info"))))))
+ (home-page "http://www.gnu.org/prep/standards/")
+ (synopsis "GNU coding standards and maintainer information")
+ (description "The GNU Coding Standards were written by Richard Stallman
+and other GNU Project volunteers. Their purpose is to make the GNU system
+clean, consistent, and easy to install.
+
+The information for maintainers of GNU software has guidelines and advice for
+someone who is the maintainer of a GNU program on behalf of the GNU Project.")
+ (license fdl1.3+)))