summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-12-17 14:08:51 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-04-18 16:49:55 -0400
commitfd11f6f30423ea0988e93ed7d635fe2125fc7169 (patch)
tree4714bfb8f47e3a07616305687ada41e3b1019eb5 /gnu/packages/gnome.scm
parenta645a5a3bdd3e1f407a9ba44a2f3993ea66c3c60 (diff)
downloadguix-patches-fd11f6f30423ea0988e93ed7d635fe2125fc7169.tar
guix-patches-fd11f6f30423ea0988e93ed7d635fe2125fc7169.tar.gz
gnu: folks: Update to 0.13.1.
* gnu/packages/gnome.scm (folks): Update to 0.13.1. [build-system]: Use meson-build-system. [arguments]: Add 'skip-gtk-update-icon-cache' phase. [inputs]: Add readline. [native-inputs]: Add glib:bin. (cherry picked from commit e4e7160c93baceb39686ce6bd1efe833ec5593c7)
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a2982b4476..ef34eb6f2b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8330,7 +8330,7 @@ the Moka icon theme.")
(define-public folks
(package
(name "folks")
- (version "0.11.4")
+ (version "0.13.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -8339,17 +8339,28 @@ the Moka icon theme.")
"folks-" version ".tar.xz"))
(sha256
(base32
- "16hqh2gxlbx0b0hgq216hndr1m72vj54jvryzii9zqkk0g9kxc57"))))
- (build-system glib-or-gtk-build-system)
+ "0pda8sx4ap3lyri5fdrnakl29la1zkhwlc9bmnp13qigp1iwdw9x"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "meson_post_install.py"
+ (("gtk-update-icon-cache") "true"))
+ #t)))))
(inputs
`(("bdb" ,bdb)
("dbus-glib" ,dbus-glib)
("evolution-data-server" ,evolution-data-server)
("glib" ,glib)
("libgee" ,libgee)
+ ("readline" ,readline)
("telepathy-glib" ,telepathy-glib)))
(native-inputs
- `(("gobject-introspection" ,gobject-introspection)
+ `(("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("intltool" ,intltool)
("pkg-config" ,pkg-config)
("vala" ,vala)))