summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-28 12:48:52 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-28 18:04:15 +0200
commitda7a5e359761b156a632988a19fca0b6b289485a (patch)
tree09c4119e81d35aebe160275cdec76e40a9e1bbcb /gnu/packages/gnome.scm
parent35188a82570348c1c47dadf94bd273942a75c20a (diff)
downloadguix-patches-da7a5e359761b156a632988a19fca0b6b289485a.tar
guix-patches-da7a5e359761b156a632988a19fca0b6b289485a.tar.gz
gnu: libgudev: Update to 236.
* gnu/packages/gnome.scm (libgudev): Update to 236. [build-system]: Use Meson. [arguments]: Drop obsolete #:configure-flags. [propagated-inputs]: Add eudev.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2a493fc40b..352d4e7ab2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6477,25 +6477,22 @@ side panel;
(define-public libgudev
(package
(name "libgudev")
- (version "232")
+ (version "236")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
version "/" name "-" version ".tar.xz"))
(sha256
(base32
- "0q3qki451zzgdjazlgshsfzbbm0in40lyx7dyrag7kbkqnwv4k7f"))))
- (build-system gnu-build-system)
- (arguments
- '(#:configure-flags
- ;; umockdev depends on libgudev.
- (list "--disable-umockdev")))
+ "094mgjmwgsgqrr1i0vd20ynvlkihvs3vgbmpbrhswjsrdp86j0z5"))))
+ (build-system meson-build-system)
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-genmarshal, etc.
("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)))
(propagated-inputs
- `(("glib" ,glib))) ; required by gudev-1.0.pc
+ `(("glib" ,glib) ; in Requires of gudev-1.0.pc
+ ("eudev" ,eudev))) ; in Requires.private of gudev-1.0.pc
(inputs
`(("udev" ,eudev)))
(home-page "https://wiki.gnome.org/Projects/libgudev")