summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-12-08 14:45:37 +0100
committerLudovic Courtès <ludo@gnu.org>2019-12-08 23:14:03 +0100
commitd9b4022c6fd6844e42aaa503d3118bf3e3a0a441 (patch)
tree88d16a8f3c9698027f14f13346ba37582609a44d /gnu/packages/gnome.scm
parentcd4f3911c51735a173f381ddfd13c8ecc2768f78 (diff)
downloadguix-patches-d9b4022c6fd6844e42aaa503d3118bf3e3a0a441.tar
guix-patches-d9b4022c6fd6844e42aaa503d3118bf3e3a0a441.tar.gz
gnu: gedit: Build sequentially.
* gnu/packages/gnome.scm (gedit)[arguments]: Pass #:parallel-build?.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7bac1454f8..94c0d30602 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5251,6 +5251,10 @@ javascript engine and the GObject introspection framework.")
;; Otherwise, the RUNPATH will lack the final path component.
(list (string-append "-Dc_link_args=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib/gedit"))
+
+ ;; XXX: Generated .h files are sometimes used before being built.
+ #:parallel-build? #f
+
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache