summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-12-17 20:36:07 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-04-18 16:49:56 -0400
commitd5101dab538b728b1cc9cc49d38a4d12de5aba59 (patch)
tree5a3f0cda0221c2649d6dcdf0533e8c19a56a0918 /gnu/packages/gnome.scm
parent14faeadd9e946b92f39a2ba70c67fc7ee3e4dc25 (diff)
downloadguix-patches-d5101dab538b728b1cc9cc49d38a4d12de5aba59.tar
guix-patches-d5101dab538b728b1cc9cc49d38a4d12de5aba59.tar.gz
gnu: gnome-screenshot: Update to 3.34.0.
* gnu/packages/gnome.scm (gnome-screenshot): Update to 3.34.0. [arguments]: Add 'skip-gtk-update-icon-cache' phase. [native-inputs]: Remove gtk+:bin. (cherry picked from commit e822ab3c7b6072c053b25a175ba802b515edff44)
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4119c0ccfd..453e6555e9 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7581,7 +7581,7 @@ can add your own files to the collection.")
(define-public gnome-screenshot
(package
(name "gnome-screenshot")
- (version "3.32.0")
+ (version "3.34.0")
(source
(origin
(method url-fetch)
@@ -7590,11 +7590,19 @@ can add your own files to the collection.")
name "-" version ".tar.xz"))
(sha256
(base32
- "09ha7dizjm5ymqpjyrqd10ijfb3xlqc1mwg9ajkrbfry11q9yq4b"))))
+ "1rmiq890j7gfn5mcz31xy6jfnnxgc17dq67bhn2k9m5ylbvza2n8"))))
(build-system meson-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "build-aux/postinstall.py"
+ (("gtk-update-icon-cache") "true"))
+ #t)))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
- ("gtk+-bin" ,gtk+ "bin") ; for gtk-update-icon-cache
("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
("intltool" ,intltool)
("appstream-glib" ,appstream-glib)