summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2017-12-18 11:10:27 +0100
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-12-27 16:14:44 +0100
commitaa498fc00320d38a37668e2b024bdc7337434c07 (patch)
tree15daa94dbcf9e31817d0845f6ebd29a4df4f18d4 /gnu/packages/gnome.scm
parent90205b625e947b4ff5286696c8a9d221a2e0326b (diff)
downloadguix-patches-aa498fc00320d38a37668e2b024bdc7337434c07.tar
guix-patches-aa498fc00320d38a37668e2b024bdc7337434c07.tar.gz
gnu: lollypop: Use meson-build-system, update to 0.9.306.
* gnu/packages/gnome.scm (lollypop) [origin]: Update version to 0.9.306, download tarball from gitlab. [build-system]: Use meson-build-system. [arguments]: Remove phases for "pseudo meson build system". [native-inputs]: Add glib:bin and gtk+:bin, remove ninja. [inputs]: Remove gtk+ and meson.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm30
1 files changed, 9 insertions, 21 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 23b3f55d52..d17b5820fb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6927,35 +6927,24 @@ views can be printed as PDF or PostScript files, or exported to HTML.")
(define-public lollypop
(package
(name "lollypop")
- (version "0.9.304")
+ (version "0.9.306")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/gnumdk/lollypop/"
- "releases/download/" version "/"
+ (uri (string-append "https://gitlab.gnome.org/gnumdk/lollypop/uploads/"
+ "b769805b7063ef9807e4e832e7e87ad2/"
name "-" version ".tar.xz"))
(sha256
(base32
- "070y6wf1180hbl1ix8al7fmc6y06jb5m14h73g509g4xbwlk62g8"))))
- ;; TODO: Use meson-build-system
- (build-system glib-or-gtk-build-system)
+ "0c49v6793bywvh295xbii9yq21hh3qpmxwbgp9i71kj6r9grvhan"))))
+ (build-system meson-build-system)
(arguments
`(#:imported-modules ((guix build python-build-system)
- ,@%glib-or-gtk-build-system-modules)
+ ,@%meson-build-system-modules)
+ #:glib-or-gtk? #t
#:tests? #f ; no test suite
#:phases
(modify-phases %standard-phases
- (delete 'configure)
- (replace 'build
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; remove post-install script, we update the caches later
- (substitute* "meson.build"
- (("meson.add_install_script\\('meson_post_install.py'\\)") ""))
- (zero?
- (system* "meson" "builddir" (string-append "--prefix=" out))))))
- (replace 'install
- (lambda _ (zero? (system* "ninja" "-C" "builddir" "install"))))
(add-after 'install 'wrap-program
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -6968,16 +6957,15 @@ views can be printed as PDF or PostScript files, or exported to HTML.")
(native-inputs
`(("intltool" ,intltool)
("itstool" ,itstool)
- ("ninja" ,ninja)
+ ("glib:bin" ,glib "bin") ; For glib-compile-resources
+ ("gtk+:bin" ,gtk+ "bin") ; For gtk-update-icon-cache
("pkg-config" ,pkg-config)))
(inputs
`(("gobject-introspection" ,gobject-introspection)
("gst-plugins-base" ,gst-plugins-base)
- ("gtk+" ,gtk+)
("libnotify" ,libnotify)
("libsecret" ,libsecret)
("libsoup" ,libsoup)
- ("meson" ,meson)
("python" ,python)
("python-beautifulsoup4" ,python-beautifulsoup4)
("python-gst" ,python-gst)