summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-12 19:01:35 +0100
committerMarius Bakke <marius@gnu.org>2020-12-13 21:44:11 +0100
commit916f2414f0dd26c67075c028cb1486446b9c051e (patch)
tree96135eb2f291833e78f7def4efe97ddfb453d6a6 /gnu/packages/gnome.scm
parent0ac61e698058646c7552982869e69227dd2c716c (diff)
downloadguix-patches-916f2414f0dd26c67075c028cb1486446b9c051e.tar
guix-patches-916f2414f0dd26c67075c028cb1486446b9c051e.tar.gz
gnu: libnotify: Update to 0.7.9.
* gnu/packages/gnome.scm (libnotify): Update to 0.7.9. [build-system]: Change to MESON-BUILD-SYSTEM. [arguments]: Remove #:configure-flags. Add #:phases. [native-inputs]: Add GTK-DOC, LIBXSLT, and DOCBOOK-XSL.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm43
1 files changed, 30 insertions, 13 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 64fded105a..4137a12c2f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2945,19 +2945,31 @@ configuring CUPS.")
(define-public libnotify
(package
(name "libnotify")
- (version "0.7.7")
+ (version "0.7.9")
(source
(origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "017wgq9n00hx39n0hm784zn18hl721hbaijda868cm96bcqwxd4w"))))
- (build-system gnu-build-system)
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0qa7cx6ra5hwqnxw95b9svgjg5q6ynm8y843iqjszxvds5z53h36"))))
+ (build-system meson-build-system)
(arguments
- `(#:configure-flags '("--disable-static")))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-docbook
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Don't attempt to download XSL schema.
+ (substitute* "meson.build"
+ (("http://docbook.sourceforge.net/release/xsl-ns/current\
+/manpages/docbook.xsl")
+ (string-append (assoc-ref inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl)
+ "/manpages/docbook.xsl")))
+ #t)))))
(propagated-inputs
`(;; In Requires of libnotify.pc.
("gdk-pixbuf" ,gdk-pixbuf)
@@ -2966,9 +2978,14 @@ configuring CUPS.")
`(("gtk+" ,gtk+)
("libpng" ,libpng)))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("glib" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)))
+ `(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+
+ ;; For the documentation.
+ ("gtk-doc" ,gtk-doc)
+ ("xsltproc" ,libxslt)
+ ("docbook-xsl" ,docbook-xsl)))
(home-page "https://developer-next.gnome.org/libnotify/")
(synopsis
"GNOME desktop notification library")